Jump to content
  • 0
Sandro

[Funtoo Stable 64 Desktop] : difficulties with updates

Question

Hi to all; 

Trying:

# emerge -DNu world

I obtain:

ci74771ht ~ # emerge -DNu world   
Calculating dependencies... done!
 
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
 
sys-devel/llvm:0
 
  (sys-devel/llvm-3.5.0::gentoo, ebuild scheduled for merge) pulled in by
    ~sys-devel/llvm-3.5.0[clang(-),debug=,multitarget?,python?,static-analyzer,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-3.5.0-r100::gentoo, ebuild scheduled for merge)
 
  (sys-devel/llvm-3.3-r3::gentoo, installed) pulled in by
    >=sys-devel/llvm-3.3-r3:0/3.3=[abi_x86_64(-)] required by (media-libs/mesa-10.2.8::gentoo, installed)
 
 
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
 
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
 
 
!!! The ebuild selected to satisfy "media-gfx/nvidia-cg-toolkit" has unmet requirements.
- media-gfx/nvidia-cg-toolkit-3.1.0013-r3::gentoo USE="(multilib) -doc -examples"
 
  The following REQUIRED_USE flag constraints are unsatisfied:
    amd64? ( multilib? ( abi_x86_32 ) )
 
  The above constraints are a subset of the following complete expression:
    amd64? ( multilib? ( abi_x86_32 ) ) any-of ( abi_x86_32 abi_x86_64 )
 
(dependency required by "media-libs/libprojectm-2.1.0-r1[video_cards_nvidia]" [installed])
(dependency required by "media-tv/xbmc-13.2-r1[projectm]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
How to solve ?
 
I don't know how to set the ABI variables :(
 
looking at "emerge --info" i've ABI_x86="64"
 
Thanks.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Ok; i'm temporarily solved Disabling locally projectm

 

# euse -D projectm -p media-tv/xbmc

 

But there is a better way to solve the trouble ?

 

Thanks if there is some explanation about projectm :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...