Jump to content
  • 0
Sign in to follow this  
willm

No Modules After Install

Question

Hello!

 

New to the forums, and Funtoo. Bit of background: I am a crazy 14-year-old Linux user who is advancing in Linux every day. I discovered Ubuntu when I was 9, and ran 8.04 alongside Windows on a netbook. I have memorised installs like Arch and Slackware, and dislike systems. Jumping to March 2014. I was at peak of curiosity at this point I think, and installed Gentoo on a desktop and a laptop. These weren't very powerful, but I developed a love for compiling. I have compiled 7 kernels and 5 of them have actually worked :D

 

Jump to October 2014. I bought a Lenovo G505 laptop from Tesco Direct. This has a AMD A6-5200 quad core APU that runs at 2 GHz and has 4 GB of RAM (I will hopefully be upgrading some time soon). This has Windows 8.1 preinstalled with UEFI. I then nagged my dad if I could dual boot, and have tried a few distributions on it which have worked beautifully. I have got used to UEFI and GPT partitioning now, so I decided to go for Funtoo. I have installed this successfully using systemrescuecd and chroot. I love your wiki as it is more pleasing to the eye than Gentoo, which quickly gave me headaches :/

 

My problem: after install, I have no Ethernet or wireless. These are compiled into the kernel as I compiled it from source and checked over twice. The thing is, if I type lsmod in the installed system, I get the three columns with nothing in them. Also modprobe does not load any modules. I have windows, a android tablet, and of course systemrescuecd for a connection at the moment. This has confused me greatly. I will attach a dmesg when I am booted into the system as I am currently on my tablet.

 

Any help would be appreciated!

 

Thanks

 

Will

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

lol now to really rub it in.....  (you could of just ran "make modules_install" and rebooted) LOL i always run them as blocks....  so its line 1...  then line 2....  then line 3....  then line 4....  then line 5.  you'll remember it better in the future by such a painful rebuilding experience.

Share this post


Link to post
Share on other sites
  • 0

cd /usr/src/linux(-versionnumber (optional))

"make clean && make distclean && make mrproper" < sanatize

"cp /boot/config-(versionnumber) .config" < copy old configs if any

"make menuconfig" < adjust configurations or just exit to accept defaults if anythings changed

"make && make modules_install && make install" <--- didja do dis?

Share this post


Link to post
Share on other sites
  • 0

AH! Hit the nail on the head (WELL, not hit yet...) I didn't do "make modules_install" or "make install"

 

I did "cd /usr/src/linux" "make clean && make distclean && make mrproper" then copied the configs from proc (systemrescuecd), then "make menuconfig" to edit the config, then "make -j5" and copied the bzImage and System.map to /boot (which is the EFI partition)

 

Ok. Time to put this in action and I'll post back if stuff happens :)

Share this post


Link to post
Share on other sites
  • 0

I did run that and reboot though! I was trying to skip around compiling it all again lol

 

I ran into issues with xkeyboard-config but just figured out I was missing get text. That problem came after the modules and I woke up at 4:30 thinking "gotta fix this ahhhhhh...."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...