Jump to content
  • 0

Unable to install xorg-server [SOLVED]


walterw
 Share

Question

I am unable to install xorg-server, I am having a problem with gl?  This looks oddly familiar to this:

However, I have already done the same...  Furthermore, to disable glamor, I removed support for ATI video cards since everything I run is Intel:

/etc/make.conf

VIDEO_CARDS="intel nouveau"

/etc/portage/package.use/xorg

x11-base/xorg-server -glamor -glvnd udev

 

checking for GL... no
configure: error: Package requirements (glproto >= 1.4.17 gl >= 9.2.0) were not met:

Package dependency requirement 'gl >= 9.2.0' could not be satisfied.
Package 'gl' has version '1.2', required version is '>= 9.2.0'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GL_CFLAGS
and GL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-base/xorg-server-1.20.5/work/xorg-server-1.20.5_build/config.log
 * ERROR: x11-base/xorg-server-1.20.5::xorg-kit failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *               ebuild.sh, line   93:  Called src_configure
 *             environment, line 3608:  Called xorg-2_src_configure
 *             environment, line 4661:  Called autotools-utils_src_configure
 *             environment, line  995:  Called econf '--docdir=/usr/share/doc/xorg-server-1.20.5' '--enable-shared' '--disable-static' '--disable-selective-werror' '--enable-ipv6' '--disable-debug' '--disable-dmx' '--enable-glamor' '--disable-kdrive' '--disable-libunwind' '--disable-xwayland' '--enable-record' '--enable-xfree86-utils' '--enable-dri' '--enable-dri2' '--enable-glx' '--disable-xcsecurity' '--disable-xephyr' '--disable-xnest' '--enable-xorg' '--enable-xvfb' '--enable-config-udev' '--without-doxygen' '--without-xmlto' '--without-systemd-daemon' '--disable-systemd-logind' '--disable-suid-wrapper' '--enable-install-setuid' '--enable-libdrm' '--sysconfdir=/etc/X11' '--localstatedir=/var' '--with-fontrootdir=/usr/share/fonts' '--with-xkb-output=/var/lib/xkb' '--disable-config-hal' '--disable-linux-acpi' '--without-dtrace' '--without-fop' '--with-os-vendor=Gentoo' '--with-sha1=libcrypto'
 *        phase-helpers.sh, line  718:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  119:  Called die
 * The specific snippet of code:
 *           die "$@"
 * 
 * If you need support, post the output of `emerge --info '=x11-base/xorg-server-1.20.5::xorg-kit'`,
 * the complete build log and the output of `emerge -pqv '=x11-base/xorg-server-1.20.5::xorg-kit'`.
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.20.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.20.5/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-base/xorg-server-1.20.5/work/xorg-server-1.20.5_build'
 * S: '/var/tmp/portage/x11-base/xorg-server-1.20.5/work/xorg-server-1.20.5'

>>> Failed to emerge x11-base/xorg-server-1.20.5, Log file:

>>>  '/var/tmp/portage/x11-base/xorg-server-1.20.5/temp/build.log'


 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Remove

2 hours ago, walterw said:

x11-base/xorg-server -glamor -glvnd udev

You must enable glvnd to pull in mesa which pulls in glproto for xorg-server-1.20.5

rj@funtoo ~ $ USE="glvnd"; for PKG in $(equery -q hasuse $USE); do echo $PKG: $(equery -q uses $PKG |grep $USE); done
media-libs/mesa-19.1.4: +glvnd
virtual/opengl-7.0-r4: +glvnd
x11-base/xorg-server-1.20.5: +glvnd
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...