Jump to content
funtoo forums
  • 0
uudruid74

Gedit thinks I need more vapigen

Question

configure of gedit (with the vala use flag, but manually running ./configure --enable-vala=yes) says ...

checking whether to forbid deprecated symbols... no
checking for itstool... itstool
checking for xmllint... xmllint
checking for gobject-introspection... yes
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
configure: error: vapigen >= 0.25.1 not found
Taro gedit-3.14.0 # vapigen-0.2
vapigen-0.22  vapigen-0.24  vapigen-0.26  

OK, here is the section of ./configure that is failing.   Notice all the tests that don't have variables in them.

esac

  if test "x" = "x"; then :

      vapigen_pkg_name=vapigen

else

      vapigen_pkg_name=vapigen-

fi
  if test "x0.25.1" = "x"; then :

      vapigen_pkg="$vapigen_pkg_name"

else

      vapigen_pkg="$vapigen_pkg_name >= 0.25.1"

fi

Is this a bug in the ebuild?  If so, how did it get unmasked?  Or is there no unit testing to make sure each USE flag works?
 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

i'm not able to reproduce it, please sync again.

 

Did you have the vala USE flag on?  Masking that flag for this build will fix it, but its kinda pointless to have the flag if it doesn't work.  And I just did a sync a few hours ago and it didn't fix it.  I just did ANOTHER sync (I'm sure glad funtoo uses git and not rsync) and it looks like it might work this time!  I always update dependencies and such, so its pulling in a few updates before it does gedit - and its done!  SOLVED

 

I know that packages are sometimes masked for testing.  Is it possible to mask a package by USE flags and version and not just version?  If this were possible, you could get the latest version where a particular set of USE flags was tested and working.  If you need a newer version, turn off a broken flag to unmask the newer one.  If you needed to add a USE flag, it would automatically mask the package version that has problems and warn the user you have to downgrade.

 

But that would depend on a lot of community feedback as to what works and what doesn't.  Anyway - it was just an idea.

Share this post


Link to post
Share on other sites
  • 0

OK cool.  Will try it tonight (I removed the vala flag for that build to work around it for now).  Any ideas on PHP?  I've re-emerged the whole system and PHP is the only one that refuses to build :/   Maybe it will be better after the sync.  I just don't like syncing that often because I want to stick with a more or less stable set of packages that all build correctly, plus we're bandwith limited here so running out of monthly allotment is an issue.

Share this post


Link to post
Share on other sites
  • 0

Fresh sync

emerge: there are no ebuilds built with USE flags to satisfy "dev-lang/vala:0.26[vapigen]".
!!! One of the following packages is required to complete your request:
- dev-lang/vala-0.26.1::gentoo (Missing IUSE: vapigen)
(dependency required by "app-editors/gedit-3.14.0[vala]" [ebuild])
(dependency required by "gedit" [argument])

I'm too tired to look at it

Share this post


Link to post
Share on other sites
  • 0

configure of gedit (with the vala use flag, but manually running ./configure --enable-vala=yes) says ...

checking whether to forbid deprecated symbols... no
checking for itstool... itstool
checking for xmllint... xmllint
checking for gobject-introspection... yes
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
configure: error: vapigen >= 0.25.1 not found
Taro gedit-3.14.0 # vapigen-0.2
vapigen-0.22  vapigen-0.24  vapigen-0.26  

 

Oh yes the vapigen problem.  I ran into just this identical error while building packages for Archlinux.....

Damned if I can remember how I fixed it!@?#!!  [rummaging through notes...] 

 

Well according to my notes this error is reported to occur in several distros including Archlinux,

Ubuntu, and Gentoo.  It was discussed in Gentoo forums, see here.

It has been reported as an error to the Gnome developers and seems to recur because they keep changing this stuff.

 

If I can think of a workaround for you I'll come back...

 

Good luck with vala.  It looks like a very nice modern (functional) language.  I'll try installing gedit/vala later in the day and see if I learn

anything about your problem...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...