Jump to content
funtoo forums
  • 0
aitikin

Upgrading to 1.4 - issues with @world - SOLVED

Question

Following the directions here:

https://www.funtoo.org/Upgrade_Instructions/1.4-release

I get to the portion of the guide to do the World update and run into issues:

emerge -auDN @world --jobs=3 --exclude dev-lang/perl --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-8.0:0/8::core-kit, ebuild scheduled for merge) pulled in by
    >=sys-libs/readline-8.0:0= required by (app-shells/bash-5.0_p7:0/0::core-kit, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                         

  (sys-libs/readline-7.0_p5:0/7::core-kit, ebuild scheduled for merge) pulled in by
    sys-libs/readline:0/7= required by (dev-lang/ruby-2.5.5:2.5/2.5::ruby-kit, installed)
                     ^^^^^                                                                                                   
    sys-libs/readline:0/7= required by (sys-fs/lvm2-2.02.173:0/0::core-kit, installed)
                     ^^^^^                                                                                                
    sys-libs/readline:0/7= required by (dev-lang/ruby-2.6.3:2.6/2.6::ruby-kit, installed)
                     ^^^^^                                                                                                   
    >=sys-libs/readline-4.1:0/7= required by (sys-devel/bc-1.07.1-r2:0/0::core-kit, installed)
                           ^^^^^                                                                                                  

dev-libs/apr:1

  (dev-libs/apr-1.7.0-r1:1/1.7::dev-kit, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/apr-1.6.5-r1:1/1.6::dev-kit, ebuild scheduled for merge) pulled in by
    >=dev-libs/apr-1.5.1:1/1.6= required by (www-servers/apache-2.4.39:2/2::core-server-kit, installed)
                        ^^^^^^^                                                                                                            
    >=dev-libs/apr-1.5.0:1/1.6= required by (app-admin/apache-tools-2.4.39:0/0::core-server-kit, installed)
                        ^^^^^^^                                                                                                                
    >=dev-libs/apr-1.6.2:1/1.6= required by (dev-libs/apr-util-1.6.1-r3:1/1::dev-kit, installed)
                        ^^^^^^^                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (sys-libs/readline-8.0:0/8::core-kit, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/python-2.7.15:2.7/2.7::python-kit, ebuild scheduled for merge)
    (dev-lang/python-3.6.8:3.6/3.6m::python-kit, ebuild scheduled for merge)

!!! All ebuilds that could satisfy "=dev-lang/perl-5.28*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/perl-5.28.0::perl-kit (masked by: exclude option)

(dependency required by "virtual/perl-File-Spec-3.740.0::perl-kit" [ebuild])
(dependency required by "net-firewall/ferm-2.4.1::net-kit" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

epro output:

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: intel64-ivybridge
      flavor: server
     mix-ins: console-extras


=== Python kit: ===

      branch: 3.7-release

=== All inherited flavor from server flavor: ===

                            core (from server flavor)
                         minimal (from core flavor)

Looks to me like this is something that might need to be fixed upstream, but I'm far from the best at diagnosing, thoughts?

Edited by aitikin
solved

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
21 minutes ago, bcowan said:

For some reason doing anything with perl before @world update seems to mess up the dep graph.

Weird, but that appears to have solved it.  Thanks, I added a brief note to the wiki.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...