Jump to content
  • 0
Sign in to follow this  
minou666

Problem with sddm theme

Question

I have no problem running kde with startx but sddm or lightdm cannot load it.

I had no problem with lightdm when I was running mate

I thought at first that it was just refusing my password but when I entered a bogus password I had a different result.

The password is accepted and I get a black screen and it gets back to the prompt.

I setup the autologin and still get to the prompt asking for the login and password.

I tried the theme and got some errors, so it looks like it cannot load the themes

I followed the wiki closely so I assumed that I have all the needed files, what is missing?

The monitor is a 4k monitor.

 

michel@localhost ~ $ sddm-greeter --theme /usr/share/themes/breeze
[23:32:02.279] (II) GREETER: High-DPI autoscaling not Enabled
[23:32:02.280] (WW) GREETER: could not connect to display
[23:32:02.280] (II) GREETER: Could not load the Qt platform plugin "xcb" in "" even though it was found.
[23:32:02.280] (EE) GREETER: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, minimal, offscreen, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

 

Michel

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The Qt platform plugin "xcb" is named libqxcb.so

$ equery b libqxcb.so
 * Searching for libqxcb.so ... 
dev-qt/qtgui-5.11.2-r1 (/usr/lib64/qt5/plugins/platforms/libqxcb.so)

Run ldd against the absolute path to libqxcb.so to verify it's linked to all the required libraries.

$ ldd /usr/lib64/qt5/plugins/platforms/libqxcb.so | grep 'not found'

 

Share this post


Link to post
Share on other sites
  • 0

localhost ~ # ldd /usr/lib64/qt5/plugins/platforms/libqxcb.so | grep 'not found'

localhost ~ # equery b libqxcb.so

* Searching for libqxcb.so ...

dev-qt/qtgui-5.12.3-r1 (/usr/lib64/qt5/plugins/platforms/libqxcb.so)

Share this post


Link to post
Share on other sites
  • 0

For debug output, as regular user type this and hit enter:

export QT_DEBUG_PLUGINS=1

Sddm includes elarun , maldives, and maya themes located in the /usr/share/sddm/themes directory

Type this command to test sddm-greeter display using elarun theme as regular user, hit enter:

sddm-greeter --test-mode --theme /usr/share/sddm/themes/elarun

Qt5 debug messages from terminal  on my lxde system that displays the theme properly.

If you have a malfunction there should be errors in the debug output pointing to the problem.

 

 

Share this post


Link to post
Share on other sites
  • 0

localhost ~ # sddm-greeter --test-mode --theme /usr/share/sddm/themes/elarun

-bash: sddm-greeter : commande introuvable

 

Share this post


Link to post
Share on other sites
  • 0

I got it fixed by running kde with startx and running the system settings. 

 

Now I got to figure out how to get a good resolution on the 1080 monitor that doesn't look like a vic20 resolution.

Setting the 4k monitor DPI to 130 from 96 make the display on the 1080 monitor unacceptable. 

 

One thing amusing, I am labeled as newbie which is a bit off considering that I have been using gentoo for many years and Funtoo for the past 2-3 years

I started Linux with Yggdrasil Linux back in the 90s when IBM announced the end of their OS/2 support. I earn my living with embedded Linux.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...