Jump to content
funtoo forums
  • 0
Sign in to follow this  
pross

Unable to update mysql

Question

pross /etc/portage # emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] dev-libs/openssl-1.0.2q [1.0.2p-r1]
[ebuild  rR    ] dev-perl/Net-SSLeay-1.800.0
[ebuild  rR    ] app-admin/mongo-tools-4.0.4
[ebuild  rR    ] www-servers/nginx-1.15.2-r1
[ebuild  rR    ] dev-lang/python-2.7.15
[ebuild  rR    ] dev-lang/python-3.6.5-r1
[ebuild     U  ] sys-devel/gettext-0.19.8.1-r1 [0.19.8.1]
[ebuild     U  ] net-libs/nghttp2-1.35.0 [1.34.0]
[ebuild  rR    ] net-misc/curl-7.61.0
[ebuild  rR    ] net-misc/wget-1.19.5
[ebuild  rR    ] app-crypt/rhash-1.3.6-r1
[ebuild     U  ] dev-python/setuptools-40.6.2 [40.0.0]
[ebuild     U  ] dev-python/cython-0.29.1 [0.29]
[ebuild  rR    ] dev-python/cryptography-2.3
[ebuild  rR    ] dev-vcs/git-2.15.2
[ebuild  rR    ] app-forensics/yara-3.8.1
[ebuild  rR    ] dev-db/mongodb-3.6.2
[ebuild  rR    ] app-arch/libarchive-3.3.2
[ebuild  rR    ] mail-mta/ssmtp-2.64-r3
[ebuild  rR    ] net-libs/serf-1.3.9
[ebuild  rR    ] net-misc/openssh-7.6_p1-r2
[ebuild  N     ] dev-db/mysql-connector-c-6.1.11  USE="ssl -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] dev-lang/php-7.3.0_rc6 [7.3.0_rc5]
[ebuild  rR    ] dev-lang/php-7.2.12
[ebuild  rR    ] dev-lang/php-7.1.24
[ebuild     U  ] dev-db/mysql-init-scripts-2.2-r4 [2.2-r2]
[ebuild     U  ] app-admin/ego-2.7.0 [2.6.3]
[ebuild  rR    ] dev-db/mysql-5.6.39
[blocks B      ] dev-db/mysql[client-libs(+)] ("dev-db/mysql[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mysql-5.6.39:0/18::dev-kit, ebuild scheduled for merge) pulled in by
    dev-db/mysql:0/18[client-libs(+),static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql:0/18[client-libs(+),abi_x86_64(-)]) required by (virtual/libmysqlclient-18:0/18::dev-kit, installed)
    dev-db/mysql required by @selected
    dev-db/mysql:0 required by @__auto_slot_operator_replace_installed__
    >=dev-db/mysql-5.6[embedded(-)?,server?,static?] (>=dev-db/mysql-5.6[server]) required by (virtual/mysql-5.6-r12:0/18::dev-kit, installed)

  (dev-db/mysql-connector-c-6.1.11:0/18::dev-kit, ebuild scheduled for merge) pulled in by
    dev-db/mysql-connector-c required by (dev-db/mysql-init-scripts-2.2-r4:0/0::dev-kit, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/openssl-1.0.2q:0/1.0.2q::core-kit, ebuild scheduled for merge) causes rebuilds for:
    (www-servers/nginx-1.15.2-r1:0/0::net-kit, ebuild scheduled for merge)
    (dev-lang/php-7.2.12:7.2/7.2::php-kit, ebuild scheduled for merge)
    (dev-lang/php-7.1.24:7.1/7.1::php-kit, ebuild scheduled for merge)
    (net-libs/serf-1.3.9:1/1::net-kit, ebuild scheduled for merge)
    (net-misc/curl-7.61.0:0/0::core-kit, ebuild scheduled for merge)
    (dev-lang/python-3.6.5-r1:3.6/3.6m::python-kit, ebuild scheduled for merge)
    (app-forensics/yara-3.8.1:0/0::nokit, ebuild scheduled for merge)
    (net-misc/wget-1.19.5:0/0::core-kit, ebuild scheduled for merge)
    (app-arch/libarchive-3.3.2:0/13::core-kit, ebuild scheduled for merge)
    (app-crypt/rhash-1.3.6-r1:0/0::nokit, ebuild scheduled for merge)
    (dev-python/cryptography-2.3:0/0::core-kit, ebuild scheduled for merge)
    (dev-lang/python-2.7.15:2.7/2.7::python-kit, ebuild scheduled for merge)
    (net-misc/openssh-7.6_p1-r2:0/0::core-kit, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.800.0:0/0::perl-kit, ebuild scheduled for merge)
    (dev-vcs/git-2.15.2:0/0::core-kit, ebuild scheduled for merge)
    (app-admin/mongo-tools-4.0.4:0/0::nokit, ebuild scheduled for merge)
    (mail-mta/ssmtp-2.64-r3:0/0::net-kit, ebuild scheduled for merge)
    (dev-db/mongodb-3.6.2:0/0::dev-kit, ebuild scheduled for merge)
    (dev-db/mysql-5.6.39:0/18::dev-kit, ebuild scheduled for merge)

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 11/27/2018 at 4:13 AM, cardinal said:

File a report at bugs.funtoo.org 

I tried that, bugs.funtoo.org just redirected me to the container ticket support, I couldnt find a way to get back to the bugs page .. stuck in a redirect loop. So I opened a container ticket instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×