Jump to content
funtoo forums
  • 0
savasten

Masked by corruption

Question

!!! All ebuilds that could satisfy "gcc" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/gcc-7.3.0::core-kit (masked by: corruption)
- sys-devel/gcc-7.2.0::core-kit (masked by: corruption)
- sys-devel/gcc-6.4.0::core-kit (masked by: corruption)
- sys-devel/gcc-6.3.0::core-kit (masked by: corruption)
- sys-devel/gcc-5.4.0-r1::core-kit (masked by: corruption)
- sys-devel/gcc-5.4.0::core-kit (masked by: corruption)
- sys-devel/gcc-5.3.0-r2::core-kit (masked by: corruption)
- sys-devel/gcc-5.3.0-r1::core-kit (masked by: corruption)
- sys-devel/gcc-4.9.4-r1::core-kit (masked by: corruption)
- sys-devel/gcc-4.9.4::core-kit (masked by: corruption)
- sys-devel/gcc-4.8.5-r1::core-kit (masked by: corruption)

 

I have got my system in a very sorry state.  Trying to run on 1.3. 

If i try and emerge gcc I get the previous errors not sure where to start.  Updated portage, replaced the /var/git/meta-repo

Any pointers would be great.

 

Thank you

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I understand but I got myself in a messy situation.  I am having trouble staying at 1.2 due to running perl 5.28 and the changes that happened.  I was running 5.28 then updated to 1.2 then the perl kit 5.28-release was depreciated. Kit system changes.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×