Jump to content
funtoo forums
rspartz

[SOLVED] samba emerge: there are no ebuilds to satisfy

Recommended Posts

I am trying to emerge samba on a fresh, funtoo install. I did change my flavor from 'core' to 'workstation' and set about updating world because of new USE flags. Once that was done, I've tried this and I am stuck:

northstar ~ # emerge -a net-fs/samba

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=sys-libs/talloc-2.1.14[python?,python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "net-fs/samba-4.9.0::net-kit" [ebuild])
(dependency required by "net-fs/samba" [argument])
northstar ~ #

 

This paste refers to sys-libs/talloc - I've re-merged that already and ran this again. It keeps stopping and will show a different lib that I re-emerge, but it is like in a loop. I've even tried changing my default version of python between 2.7 and 3.6. Still no luck.

I've tried searching for solutions but I am stuck. If this is *an easy one* I am apologizing for it right now.

Thanks to all who read this! ;^)

(attached is my emerge info)

 

 

 

 

 

 

 

 

emerge_info.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×