Jump to content
funtoo forums
  • 0

I'm not able to emerge world.


ci74771ht ~ # emerge -DNu world
Calculating dependencies... done!

Oops! Conflicts have been encountered:                                                                
>>> media-tv/kodi-17.6-r2:0/0::media-kit, installed, wants <media-video/ffmpeg-3.4                    

My candidates are:
>>> media-video/ffmpeg-3.4.1:0/55.57.57::media-kit, ebuild scheduled for merge has SLOT 0/55.57.57    
>>> media-video/ffmpeg-3.3.6:0/55.57.57::media-kit, installed has SLOT 0/55.57.57

We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.60.0::core-kit (Change USE: +curl_ssl_nss, this change violates use flag constraint
s defined by net-misc/curl-7.60.0: 'curl_ssl_winssl? ( elibc_Winnt ) threads? ( !adns ) ssl? ( exactl
y-one-of ( curl_ssl_axtls curl_ssl_gnutls curl_ssl_libressl curl_ssl_mbedtls curl_ssl_nss curl_ssl_op
enssl curl_ssl_winssl ) )')
(dependency required by "net-libs/liboauth-1.0.3::security-kit[nss,curl]" [ebuild])
(dependency required by "dev-libs/libgdata-0.17.5::gnome-kit" [installed])
(dependency required by "gnome-extra/evolution-data-server-3.20.6::gnome-kit" [installed])
(dependency required by "net-im/pidgin-2.13.0::net-kit" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
ci74771ht ~ #


Thx for any suggesition.

Share this post

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

I would guess that the system wants to enable the USE flag curl_ssl_nss for the package curl because the USE flag nss is set for the package liboauth.

I get the same error when I want to reinstall liboauth. It seems that ths USE flag nss got activated by the system lately.

There are not many packages that use the USE flag nss. So, if you don't need this USE flag then you could deactivate it globally or for liboauth only and you should be fine.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...