Jump to content
  • 0
Sign in to follow this  
paddymac

Can't switch user from Plasma 5 lock screen

Question

For some reason, if I click "Switch User" from the Plasma 5 lock screen, if I click the button to start a new session, it simply brings up the password prompt for the currently logged in user. I can't switch to a new user. I found a thread on the Gentoo forums about this same issue, and it was suggested to disable the consolekit USE flag, enable the elogind USE flag, and emerge @world to recompile everything that had a changed USE flag setting. I did that, but I had no change in the situation. I've had a desktop with OpenSUSE Leap 42.2 installed, and user switching from the Plasma 5 lock screen worked fine on that system. Does anyone have any ideas on how to get this working? It wasn't a big deal when I was the only one using the computer, but now that I'm sharing it with someone I need this feature to work.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Well, a few minutes after I wrote this question, I found this other forum post: 

It reminded me that I forgot to use rc-update to disable consolekit from default and to enable  elogind on boot. I did so, rebooted, and now it works. SDDM seems a little slow now, and I still don't know why it doesn't work with consolekit, but I think this issue is solved for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...