Jump to content
funtoo forums
  • 0
maleita

emerge @preserved-rebuild trouble

Question

Quote

emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt4]".
!!! One of the following packages is required to complete your request:
- app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt4)
(dependency required by "kde-frameworks/kdelibs-4.14.37::kde-kit[plasma]" [ebuild])
(dependency required by "@preserved-rebuild" [argument])

 

since change to 1.2........

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0
14 hours ago, maleita said:

since change to 1.2........

Here the same (?)

emerge @preserved-rebuild -av --exclude=efl

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt4]".
!!! One of the following packages is required to complete your request:
- app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt4)
(dependency required by "kde-frameworks/kdelibs-4.14.37::kde-kit[plasma]" [ebuild])
(dependency required by "kde-plasma/qguiplatformplugin_kde-4.11.22::kde-kit" [ebuild])
(dependency required by "@preserved-rebuild" [argument])

 

Share this post


Link to post
Share on other sites
  • 0
Quote

kali ~ # emerge qca -av

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-crypt/qca-2.1.3-r2:2::nokit  USE="ssl -botan -debug -doc -examples -gcrypt -gpg -libressl -logger -nss -pkcs11 -sasl -softstore {-test}" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]

 

if it was............................

Share this post


Link to post
Share on other sites
  • 0
43 minutes ago, jhan said:

Something is pulling in qt4 for qca.

Do you normally use qt4 or qt5?

I don't want actually qt4. In `make.conf` I have ` -qt3 -qt4` among the USE flags.

I am unsure about which package(s) require it. I tried to massively clean-up my system in the last days. And, it seems it worked, more or less.

There are still some quircks.

Share this post


Link to post
Share on other sites
  • 0
Quote

lculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt4]".
!!! One of the following packages is required to complete your request:
- app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt4)
(dependency required by "kde-frameworks/kdelibs-4.14.37::kde-kit[plasma]" [ebuild])
(dependency required by "@preserved-rebuild" [argument])
kali ~ #

 

Still ....................

Quote

kali ~ # emerge -DNu @world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt4]".
!!! One of the following packages is required to complete your request:
- app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt4)
(dependency required by "kde-frameworks/kdelibs-4.14.37::kde-kit[plasma]" [installed])
(dependency required by "kde-plasma/oxygen-5.12.3::kde-kit[qt4]" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.12.3::kde-kit" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
kali ~ #

 

 

Share this post


Link to post
Share on other sites
  • 0
Quote

 eix -s qca
[?] app-crypt/qca [1]
     Available versions:  (2) 2.1.3-r1
       {botan debug doc examples gcrypt gpg libressl logger nss pkcs11 qt4 +qt5 sasl softstore +ssl test}
     Installed versions:  2.1.3-r2(2)(22:17:03 08-06-2018)(ssl -botan -debug -doc -examples -gcrypt -gpg -libressl -logger -nss -pkcs11 -sasl -softstore -test)
     Homepage:            https://userbase.kde.org/QCA
     Description:         Qt Cryptographic Architecture (QCA)

[1] "nokit" /var/git/meta-repo/kits/nokit
kali ~ # emerge -av =app-crypt/qca-2.1.3-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=app-crypt/qca-2.1.3-r1".

 

good morning =app-crypt/qca-2.1.3-r1have qt4 IUSE ,but in upgrade loose the IUSE   ,need a little help , somebody forgot anything?????

Share this post


Link to post
Share on other sites
  • 0
Quote

emerge -avDNu @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/qca-2.2.0_pre20180606:2::nokit [2.1.3-r2:2::nokit] USE="ssl -botan -debug -doc -examples -gcrypt -gpg -libressl -logger -nss -pkcs11 -sasl -softstore {-test}" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]

 

There no qt4 IUSE .Somebody forgot something???????????????

Share this post


Link to post
Share on other sites
  • 0
Just now, jhan said:

If you really need qt4 support and can't live with only qt5, you should open a bug at http://bugs.funtoo.org

kali ~ # emerge --info | grep qt4
kali ~ #

i don't need is portage who needs!

Quote

kali ~ # emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt4]".
!!! One of the following packages is required to complete your request:
- app-crypt/qca-2.2.0_pre20180606::nokit (Missing IUSE: qt4)
- app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt4)
(dependency required by "kde-frameworks/kdelibs-4.14.37::kde-kit[plasma]" [ebuild])
(dependency required by "@preserved-rebuild" [argument])
kali ~ #

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, maleita said:

i don't need is portage who needs!

Exactly. And that is the reason why you should open a bug.

The problem is not qca. It is that kdelibs requires exactly and only qt4 when the USE flag plasma is selected. If you file a bug, the developers can have a look at it and decide what to do.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×