Jump to content
  • 0
rohshall

eix-update throws error

Question

When I run eix-update, I get this error:
 

Quote

[16] "nokit" /var/git/meta-repo/kits/nokit (cache: parse|ebuild*#metadata-md5#metadata-flat#assign)
     Reading category  20|165 ( 12): app-misc... * ERROR: app-misc/neofetch-9999::nokit failed (depend phase):
 *   Unsupported EAPI=7 (unknown) for git-r3
 * 
 * Call stack:
 *              ebuild.sh, line 594:  Called source '/var/git/meta-repo/kits/nokit/app-misc/neofetch/neofetch-9999.ebuild'
 *   neofetch-9999.ebuild, line   6:  Called inherit 'git-r3'
 *              ebuild.sh, line 290:  Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/git-r3.eclass'
 *              ebuild.sh, line  79:  Called source '/var/git/meta-repo/kits/core-kit/eclass/git-r3.eclass'
 *          git-r3.eclass, line  16:  Called die
 * The specific snippet of code:
 *           die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
 * 
 * If you need support, post the output of `emerge --info '=app-misc/neofetch-9999::nokit'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/neofetch-9999::nokit'`.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/neofetch-9999'

ebuild failed with status 1
 

 

I have attached the output of the following commands:

Quote

emerge --info '=app-misc/neofetch-9999::nokit'
emerge -pqv '=app-misc/neofetch-9999::nokit'
 

 

info.log

pqv.log

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...