Jump to content
funtoo forums
  • 0
Sign in to follow this  
romikb

Disable stateless ipv6 address generation

Question

I try to setup ip for server using /etc/conf.d/net.eth0

template="interface"
ipaddr="192.168.11.6/24 2a03:xxxx:xxxx:xxxx::6/64"
gateway="192.168.11.1"
gateway6="2a03:xxxx:xxxx:xxxx::"

but interface acquire 3 ipv6 addresses

# ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.11.6  netmask 255.255.255.0  broadcast 192.168.11.255
        inet6 2a03:xxxx:xxxx:xxxx:aaaa:aaaa:aaaa:aaaa  prefixlen 64  scopeid 0x0<global>
        inet6 2a03:xxxx:xxxx:xxxx::6  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::aaaa:aaaa:aaaa:aaaa  prefixlen 64  scopeid 0x20<link>
        ether aa:aa:aa:aa:aa:aa  txqueuelen 1000  (Ethernet)
        RX packets 3448832  bytes 2497999401 (2.3 GiB)
        RX errors 0  dropped 222  overruns 0  frame 0
        TX packets 4594668  bytes 5355598657 (4.9 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 
 

how can I exclude "2a03:xxxx:xxxx:xxxx:aaaa:aaaa:aaaa:aaaa"?

 

PS: neighbor discovery is enable on router and cannot be disabled because needed by other pc. 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...