Jump to content
funtoo forums
  • 0
kingbu

ecryptfs-mount-private Help!

Question

Hi Guys,

I'm struggling getting rid of ecryptfs-utils.

When I try to mount Private dir with command

ecryptfs-mount-private

I insert the correct password , I always receive the following error:

Inserted auth tok with sig [99606f6f7537a8fd] into the user session keyring
mount: Operation not permitted

Kernel error, as per log file is the following:

 

May  8 13:57:21 localhost kernel: Mount of device (uid: 0) not owned by requested user (uid: 1000)
May  8 13:57:21 localhost kernel: Reading sb failed; rc = [-1]
May  8 13:57:25 localhost kernel: Mount of device (uid: 0) not owned by requested user (uid: 1000)
May  8 13:57:25 localhost kernel: Reading sb failed; rc = [-1]


Anyone has idea on how to solve this matter?

Thanks in advance! ;-)

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

 ecryptfs-uitls  compiled with suid flag

I had too  manually deleting ~/Private ~./Private and ~/.ecryptfs ,

the I rebooted and recreated all folders with ecryptfs-setup-private

Now everything works!

Thank a lot for the help!!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...