Jump to content
funtoo forums

Question

Hi All,

Is my first time installing Funtoo, am just an hobbyist not an expert, am happy that I have been able to install it at first attempt but am experiencing a couple of problems already.
The main one prevents me to move on: I reached the point of installing SDDM (I love KDE and choosen it. Nvidia drivers installed too): reboot and it does'nt accept password.
I have been installing Lightdm too and I get the same problem. Plus, after clicking for password, the login page comes out not in correct position, leaving a black strip on the left side of the screen (image hereby attached), it goes in the right position clicking again.

I don't know the reason, maybe useful to know that during Funtoo's installation process I discovered that I have been messing up with file/folders permissions over an other distro making it unusable and I have been erasing and installing it again (Grub is there, I did'nt install it with Funtoo).
Details are:
1 - Linux-Mint /dev/sdb2 (Grub here)
2 - Funtoo /dev/sdb3
3 - Calculate Linux /dev/sdb4
(/dev/sda = Windows 10. Both disks UEFI)
(/dev/sda2 = boot efi partition)

Well, that is the main issue, I know is correct to put only one question for each discussion, but ask permission to add another couple of problems, as because am sure solution for them is very simple (I found the solution already in the forum for the first one but I am unable to understand the process suggested there), as because maybe they are related with the login issue.Problems are:
1 - during installation, terminal telling me:

Message for package
media-sound/pulseaudio-11.1:
- A preallocated buffer-size of 2048 (kb) or higher is recommended for the hd-audio driver!

CONFIG_SND_HDA_PREALLOC_SIZE=54

2 - Another message telling me that is unable to fetch
 

media-libs/schroedinger-1.0.11-r1

I don't know which details useful for you I can add. Please, if needing let me know.

Thank you for reading. Ciao (Yes, I am Italian) :)

 

Funtoo_wrong_login.jpg

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

login problems - could be related to permissions. try login from a terminal (Alt+F1, or Ctrl+Alt+F1 to reach the terminal)

CONFIG_SND_HDA_PREALLOC_SIZE=54

BUT:

For people using alsa directly, the value of this option makes no difference (as far as I know). However, with PulseAudio increasing this value will make it possible to only wake up once every two seconds when playing audio.

I suggest setting the value to 2048, as mentioned in the help text (below). As far as I know, there is no downside to this, the only reason not to increase it further is that PulseAudio does not take advantage of a value above 2048, so there would be no point.

For easy reference:

+config SND_HDA_PREALLOC_SIZE
+ int "Pre-allocated buffer size for HD-audio driver"
+ range 0 32768
+ default 64
+ help
+ Speficies the default pre-allocated buffer-size in kB for
+ HD-audio driver. A larger buffer (e.g. 2048) is preferred
+ for systems with PulseAudio. The default 64 is chosen just
+ from the compatibility reason.
+
+ Note that the pre-allocation size can be changed dynamically
+ via a proc file (/proc/asound/card*/pcm*/sub*/prealloc), too.

4 hours ago, bourbon said:

media-libs/schroedinger-1.0.11-r1

unable to reproduce this

>>> Fetching (2 of 2) media-libs/schroedinger-1.0.11-r1::media-kit
>>> Downloading 'http://distfiles.gentoo.org/distfiles/schroedinger-1.0.11.tar.gz'
--2018-04-02 02:53:33--  http://distfiles.gentoo.org/distfiles/schroedinger-1.0.11.tar.gz
Resolving distfiles.gentoo.org... 2600:3402:200:227::2, 2605:bc80:3010::134, 2600:3404:200:237::2, ...
Connecting to distfiles.gentoo.org|2600:3402:200:227::2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1019247 (995K) [application/x-gzip]
Saving to: ‘/var/cache/portage/distfiles/schroedinger-1.0.11.tar.gz’

/var/cache/portage/distf 100%[=================================>] 995.36K  2.54MB/s    in 0.4s

2018-04-02 02:53:34 (2.54 MB/s) - ‘/var/cache/portage/distfiles/schroedinger-1.0.11.tar.gz’ saved [1019247/1019247]

 * schroedinger-1.0.11.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                          [ ok ]

post the whole error message.

Share this post


Link to post
Share on other sites
  • 0

Hi Palica,

Thank you for your kind concern, I really appreciate.
Following your hint I get clue from the terminal, it says:
$ startx
xauth=  file /home/master/.serverauth.18693 does not exist
Plus other details maybe useful for you as in the embedded image.

ltfSY3p.jpg

Talking about "CONFIG_SND_HDA_PREALLOC_SIZE=64"

I saw the Sandro's topic but I don't understand what I have to do.
Do I have to write the value "2048" somewhere in the file
/proc/asound/card*/pcm*/sub*/prealloc  ?

For "media-libs/schroedinger-1.0.11-r1"  issue, got it installed today.
# emerge -a media-libs/schroedinger-1.0.11-r1 :: media-kit installed

Ciao

P.S.

I see the first post of mine is replicated three times, I don't know how to cancel the duplicates ones, maybe Administrator can do that

Share this post


Link to post
Share on other sites
  • 0

answering from bottom to top:

- duplicate posts deleted

- schroedinger fine

- what do you get when running:

zgrep SND_HDA_PREALLOC_SIZE /proc/config.gz

if the value is 2048 and you are running pulseaudio just leave it like it is. nothing needs to be done in other words. if you get anything else, upgrade to debian-sources-4.14.12 those seem to have it set by default to 2048.

- now the main problem. try stopping graphical login first and then try again with startx from you terminal.

as root:
/etc/init.d/xdm stop

as your user:
startx

let me know, or join #funtoo on IRC freenode

Share this post


Link to post
Share on other sites
  • 0

Hi Palica,

Running "zgrep SND_HDA_PREALLOC_SIZE /proc/config.gz" I get
..... SIZE=64
Meaning I have to upgrade the kernel to "debian-sources-4.14.12" following your suggestion.
Please, can you tell me the process? - I gone to Funtoo's Manual but I see blank page there and am not sure Gentoo's Manual is the right place to find the process.
After upgrading I have to cancel the old kernel, I suppose.

About the main problem: after following yours instructions I receive:

xauth: file/home/master/.serverauth.18734 does not exist

The embedded image shows the whole output.

wcLG32I.jpg

I have been joining the Funtoo's Channel on IRC but never used it before, so am not sure I will manage it properly, that's why am answering to you here too.

Ciao

Share this post


Link to post
Share on other sites
  • 0

ok, so one note the termbin addresses is better to type out. I know it is easier for you to make a camera shot, but it makes it for others very hard to read from the screenshot.

second - the Xorg.log looks good.

lets install a couple of packages and retest with your normal user account and running startx there.

install

emerge -v1 x11-wm/twm x11-apps/xclock x11-terms/xterm 

login as normal user and run

startx

 

Share this post


Link to post
Share on other sites
  • 0

I am sorry once again Palica, was thinking camera shot better than writing.

I am a bit confused, briefing:
- I gave these commands:
# emerge -v1 x11-wm/twm x11-apps/xclock
#emerge x11-apps/xclock (I don't remember if gave "-v1" at beginning)
- Two different commands because I did'nt understand if two or only one.
Coming out "X" giving $ startx here = getting three panels and a clock.
Reboot.
Lightdm refuses pw again (the window does'nt gone out of focus, no black strip on the left side).
"su" and giving:
# emerge -v1 x11-wm/twm x11-apps/xclock x11-terms/xterm
su user (master, the only one) = refuses pw
Reboot
lightdm refuses pw again ($ master = normal user)

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, bourbon said:

getting three panels and a clock.

this is good, is it with normal user or root?

also couple of things

- use

su - master

instead of just 

su master

or even better login with your user (master) directly not first as root and then su

- try to locate the logs for lightdm mostly in /var/log/lightdm and paste the one that you think shows some relevant error messages.

- can you try another display manager?

I don't use lightdm so I am just guessing here.

Share this post


Link to post
Share on other sites
  • 0
51 minutes ago, palica said:

 

     Palica asking:  getting three panels and a clock.

this is good, is it with normal user or root?


>>> Sincerely, I don't remember, but as user, I suppose
(btw I was getting it also after installing "X" before installing kde-plasma)


=======================================================
I don't have file for lightdm, have been trying with:
# nano /var/log/lightdm
and
# nano /var/log/lightdm.conf (empty file comes out)
=======================================================
After that: I have been turning off lightdm and turning on sddm.
Steps:
1 - # etc/init.d/xdm stop
2 - # /etc/portage/package.use
commenting the line "kde-plasma/plasma-meta -sddm"
3 - # nano /etc/conf.d/xdm
DISPLAYMANAGER="sddm"
4 - # rc-update add xdm default
5 - # rc
I get sddm page now, the clock is working showing the right time but still refuses the pw and comes out black strip on the left side (I did reboot too, same result)

 

 

Share this post


Link to post
Share on other sites
  • 0

well, the question kind of remains, can you login to your box as normal user (console login not graphical)? because you have shown on your screenshots that you can login as root and you then su to your user. can you login as user directly - eg. is your password set for normal user? try

ls /var/log

to locate any log files.  we are cooking from water without actual error messages.

Share this post


Link to post
Share on other sites
  • 0
well, the question kind of remains, can you login to your box as normal user (console login not graphical)?

Yes, sddm continues refusing password, so I did now:

Ctrl+Alt+F1

login = master

Password #######

I did'nt try "startx" again sure receiving again the message "server x already running"

so I gone root and gave ls /var/log

coming out a list of some files, I have been opening with nano the sddm log ( name green in color), is long, I don't see error messages there.

Only one line saying breeze theme does'nt exist.

After that reboot

Share this post


Link to post
Share on other sites
  • 0

Hi Palica,

Got new clue and am sure we are close to the solution now.

On the SDDM login page I noticed down on the left corner the session switcher: clicking on it was selected "X" session, I switched to "Plasma" session and it started but coming out the following message:
 

All shell packages missing.

This is an installation issue, please contact your distribution

Clicking "Ok" on the message black screen comes out.

===================================================================================================================

EDIT - April, 7,2018

==================

Ok Palica, I have been looking around wishing to find a solution without disturbing you, got it! - We can mark the thread as SOLVED now :) I got graphical access doing the following steps:

(I don't know if without intention skipped some steps during installation time. Please, can you tell me if everything is fine here or needing to check for unnecessary packages or any kind of mistake I did ? - Apparently, the System works smootly now)

1 - # emerge -a kde-plasma/plasma-desktop

   - # etc-update on the requested file

1a - # emerge -a dev-libs/sni-qt

1b - # emerge -a dev-libs/libappindicator:2

1c - # emerge -a dev-libs/libappindicator:3

2 - # emerge -a kde-plasma/plasma-meta

2a - # emerge -a sys-devel/gdb

2b - # emerge -a x11-themes/oxygen-gtk

===============================================================================

At this point I have only one problem to solve yet, this one:

Message for package
media-sound/pulseaudio-11.1:
- A preallocated buffer-size of 2048 (kb) or higher is recommended for the hd-audio driver!

CONFIG_SND_HDA_PREALLOC_SIZE=54

Already you told me that I have to

upgrade to debian-sources-4.14.12 those seem to have it set by default to 2048. 

Please, can tell me the steps to do that? - Including what I have to do to remove the old kernel and if needing extra steps due the installed Nvidia drivers.

Thank you

Best Regards

Edited by bourbon
Adding data

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...