Jump to content
  • 0
Sign in to follow this  
donjames

[solved] chromium emerge error

Question

Hi folks,

 

I am trying to emerge chromium and I get this error:

...
ImportError: This platform lacks a functioning sem_open implementation, therefore, the required synchronization primitives needed will not function, see issue 3770.
* ERROR: www-client/chromium-37.0.2062.68 failed (configure phase):
*   (no error message)
...

Here is the --info output:

emerge --info '=www-client/chromium-37.0.2062.68'
Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, unavailable, 3.16.1-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.16.1-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_5160_@_3.00GHz-with-gentoo-2.2.0
KiB Mem:     1013400 total,    189332 free
KiB Swap:    4194300 total,   4176460 free
Timestamp of tree: Unknown
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/python:          2.7.8-r1000, 3.3.5-r1000
dev-util/cmake:           2.8.12.2-r1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r3
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2-r3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.cs.wmich.edu/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl alsa amd64 apache apache2 apng berkdb bzip2 cdr consolekit cracklib crypt ctype cups cxx dbus device-mapper dvd extras filter frascend gd gdbm gnutls gtk hal iconv icu imap ipv6 kde lxde minizip mmx mng modules mp3 mudflap multilib mysql mysqli ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre php png policykit polkit python qt3 qt3support qt4 readline resolvconf samba sdl session sql sqlite sse sse2 ssl static-libs svg tcltk tcpd tftp threads tkinter unicode vorbis xml zlib" ABI_X86="64" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK


Can  someone give me a hint about what is happening here?

 

Thanks,

 

Don James

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

What does issue 3770 say? The error sounds kernel related. I would guess that issue 3770 will tell you that you need to enable certain option in the kernel, rebuild, and maybe reboot.

Share this post


Link to post
Share on other sites
  • 0

Hi Don James,

 

I had the same problem a while back. I remember doing a Google search which probably led me to

http://forums.gentoo.org/viewtopic-p-7465170.html

My solution was to re-emerge python:

emerge python:2.7 python

Before doing that please note the output of 

eselect python list

It might be that your default python interpreter is 3.* in which case it might be also worth trying to switch to python-2.7 (using eselect python set NUM) and then trying to reemerge chromium again. (Also, as salazaraj2 pointed out, make sure you actually have the option enabled in the kernel)

 

Hope this helps!

Share this post


Link to post
Share on other sites
  • 0

What option in the kernel?

 

I think issue 3770 has something to do with python.  I searched with google and found that a lot of other people are getting the same error message when trying to install Chromium.

 

I did 

eselect python set 1
emerge python:2.7
emerge chromium

emerge chromium seems to be working now.

 

Chromium is installed!

 

Thanks for the help.

 

Don James

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...