Jump to content
funtoo forums
  • 0
znavko

nm-dispatcher does not allow to boot after world update

Question

Hello! Funtoo is so pretty useful and fast. I want you to help me to boot in graphic mode.

Here are the errors of xorg that I solved in next reply. And the other problem is  nm-dispatcher's timeout on boot.

After running `ego sync`, `emerge --sync`, `eix-update`, `emerge --avuND --with-bdeps=y --complete-graph=y --backtrack=30 --keep-going --verbose-conflicts --exclude "gentoo-sources firefox gimp openshot glibc perl pyrhon gcc" world `

and successful complete with some yellow lines in the end my Funtoo does not start XORG and lightdm.

After boot I see this https://itmag.es/8jZn
Pressing any key gives authorization. After authorization I cannot start lightdm and xorg:

# lightdm
** (lightdm:3599): WARNING **: Failed to get list of logind seats: GDBus.Error: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .servce files

# startx
xauth: file /root/.serverauth.3572 does not exist

X.Org X Server 1.19.3
Release Date....
....
Current version of pixman: 0.34.0
....
...something about 'synclient tapbutton=1` wrong in /etc/X11/xorg.conf.d/50-synaptics.conf
...
(EE)
Fatal server error: no screens found(EE)
Please also check the file at "/var/log/Xorg.0.log" for additional information.
Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X serer: Connection refused
xinit: server error

# lspci -kv | grep VGA | nc termbin.com 9999
http://termbin.com/awwnc

# lsmod | nc termbin.com 9999
http://termbin.com/7po0

# dmesg > 111
# cat 111 | nc termbin.com 9999
http://termbin.com/eokt

 

What to do?

PS: I use debian-sources, not gentoo-sources. I copied and quickly run this line adding exceptions, did not see it has gentoo-sources atom.

Share this post


Link to post
Share on other sites

33 answers to this question

Recommended Posts

  • 1

@znavko, your reports are getting better. No we know that the problem is with your graphics card or your graphics drivers as X reports no screens found.

I would still like to know how your system was before running upgrade. Was it booting to graphical, did you startx manually ...

1 hour ago, znavko said:

`ego sync`, `emerge --sync`, `eix-update`

this can be replaced by single command =>

eix-sync

 

1 hour ago, znavko said:

--backtrack=30

no need to use this as it will make dependency resolution slower

1 hour ago, znavko said:

--exclude "gentoo-sources firefox gimp openshot glibc perl pyrhon gcc"

you don't need to exclude all these things if there is no update to these packages portage will not rebuild them that is what emerge -u is there for.

OK and now to your actual problem. nm-dispatcher is not your problem. nm-dispatcher happens to be the last think that runs from your init scripts and you think it is causing your error but it is not.

Please paste your make.conf and

eix -I "xf86-*"

and your /var/lib/portage/world file

 

Share this post


Link to post
Share on other sites
  • 0

I found one error: wrong synaptics.conf file where I wanted to add double-click using arch manual https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Synclient I added command `synclient tapbutton=1` in file.

When deleted I could `startx`

But after reboot nm-dispatcher does not allow to boot. I press enter but nothing happens https://itmag.es/5PLPW

It stops on line `nm-dispatcher: req:4 'hostname': start running ordered scripts...`

 

I also cannot boot to console using my grub line:

linux /kernel-debian-sources-x86_64-4.8.15-1 rootfstype=auto real_root=/dev/sda3 rootfstype=ext4

I added to the end 'quiet text' not helped, stops on nm-dispatcher. I added to the end 'init=/bin/sh'  not helped also.

Share this post


Link to post
Share on other sites
  • 0

Simply pressing Ctrl + Alt + F4 has run new console, where I authorized and typed `lightdm`. System booted, I authorized/

I rebooted. lightdm runs by itsels. But after I typed login and password and pressed enter nm-dispatcher run again and stopped booting again. I rebboted and nm-dispatcher stopped everything again.

I only want to know why ModemManager is so ugly, how to work with wifi without nm-dispatcher?

Also how to boot to text-mode with my so specific kernel line?

Share this post


Link to post
Share on other sites
  • 0

Humm. I was reading archlinux wiki https://wiki.archlinux.org/index.php/NetworkManager#Avoiding_the_dispatcher_timeout

I've not found scripts mentioned there in my system. But I saw others, that I do not want, here:

# pwd
/usr/lib/systemd/system

# ls
accounts-daemon.service                  iptables.service
alsa-restore.service                     lightdm.service
alsa-state.service                       lxdm.service
basic.target.wants                       mdadm-grow-continue@.service
canberra-system-bootup.service           mdadm-last-resort@.service
canberra-system-shutdown-reboot.service  mdadm-last-resort@.timer
canberra-system-shutdown.service         mdmon@.service
cups-browsed.service                     mdmonitor.service
dhcpd4.service                           pwcheck.service
dhcpd6.service                           rsyncd.service
dhcrelay4.service                        saslauthd.service
dhcrelay6.service                        slapd.service
geoclue.service                          slim.service
git-daemon.socket                        sshd.service
git-daemon@.service                      sshd.socket
gpm.service                              sshd@.service
ip6tables-restore.service                tor.service
ip6tables-store.service                  udisks2.service
ip6tables.service                        upower.service
iptables-restore.service                 xdm.service
iptables-store.service

There were wpa_supplicant's 4 services and dhcpcd services.So I deleted wpa_supplicant and have just running deleting dcpcd and saw it is system file. I aborted and run `emerge -auDN dcpcd` but got nothing.

Now I cannot install dhcpcd:

# emerge -auDN dhcpcd

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following update has been skipped due to unsatisfied dependencies:

dev-python/requests:0

  selected: dev-python/requests-2.13.0:0/0::python-kit, installed
  skipped: dev-python/requests-2.18.4:0/0::python-kit, ebuild scheduled for merge (see unsatisfied dependency below)

emerge: there are no ebuilds to satisfy ">=dev-python/certifi-2017.4.17[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.18.4::python-kit" [ebuild])

 

How to fix nm-dispatcher and install my dcpcd ? Also do I need wpa_supplicant?

Share this post


Link to post
Share on other sites
  • 0

I installed dhcpcd with this: `emerge dhcpcd`. So just 1 package pulled and installed.

When I rebooted lightdm started very well without any stops.

But nmtui did not see the wi-fi. so i boot to systemrescuecd to emerge wpa_supplicant again.

Share this post


Link to post
Share on other sites
  • 0

 

I definitely like Funtoo. I installed wpa_supplicant without any conflicts. Rebooted. I also look at this inconvenient message from nm-dispatcher and need to run another console to start lightdm.But wifi is working 8)

@palica, yes I booted into graphic mode, to LXDE before this update.

# cat /etc/portage/make.conf
 MAKEOPTS="-j5"

LINGUAS="en_US ru_RU"
L10N="${LINGUAS}"
VIDEO_CARDS="intel"
INPUT_DEVICES="evdev keyboard mouse synaptics"
CPU_FLAGS_X86="mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
CFLAGS="-march=silvermont -mno-aes -O2 -pipe"
CXXFLAGS="${CFLAGS}"
FFLAGS="${CFLAGS}"
FCFLAGS="${CFLAGS}" 

USE="alsa cairo dbus gui imagemagick introspection \
     network opengl perl printsupport \
     svg widgets \
     "
 eix -I "xf86-*"
[I] x11-drivers/xf86-input-evdev [1]
     Available versions:  2.10.5
     Installed versions:  2.10.5(21:49:20 20.12.2017)
     Homepage:            https://www.x.org/wiki/
     Description:         Generic Linux input driver

[I] x11-drivers/xf86-input-keyboard [1]
     Available versions:  1.9.0
     Installed versions:  1.9.0(21:43:56 20.12.2017)
     Homepage:            https://www.x.org/wiki/
     Description:         Keyboard input driver

[I] x11-drivers/xf86-input-mouse [1]
     Available versions:  1.9.2
     Installed versions:  1.9.2(21:48:27 20.12.2017)
     Homepage:            https://www.x.org/wiki/
     Description:         X.Org driver for mouse input devices

[I] x11-drivers/xf86-input-synaptics [1]
     Available versions:  1.9.0 {KERNEL="linux"}
     Installed versions:  1.9.0(21:47:39 20.12.2017)(KERNEL="linux")
     Homepage:            https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads

[I] x11-drivers/xf86-video-intel [1]
     Available versions:  2.99.917_p20160621-r2 2.99.917_p20170716 {debug dri +dri3 +sna +udev uxa xvmc}
     Installed versions:  2.99.917_p20170716(21:46:43 20.12.2017)(dri dri3 sna udev -debug -uxa -xvmc)
     Homepage:            https://www.x.org/wiki/
     Description:         X.Org driver for Intel cards

[1] "xorg-kit" /var/git/meta-repo/kits/xorg-kit

Found 5 matches

# cat /var/lib/portage/world | nc termbin.com 9999
http://termbin.com/gudc

 

 

 

Share this post


Link to post
Share on other sites
  • 0

@znavko, I have one plea to you, please don't fix your broken funtoo system using instructions found on archlinux wiki it will not work. Please post on this forum and then wait until someone replies if you want help from others and do not run some more commands and do stuff that you don't understand what it is doing, which makes stuff even worse for the people willing to help you.

Please train your patience a bit. So post and wait, please.

Are you running funtoo? If yes then systemd is not supported, we use openrc as our init. So anything copied from other sources will likely be false.

Once again! Please! Please! Post and wait. Do NOT run any other commands that make stuff even worse or make your posts a mess. Thank you!

Share this post


Link to post
Share on other sites
  • 0

I added world file in reply above.

# rc-status -a
Runlevel: default
 dbus                                                              [  started  ]
 NetworkManager                                                    [  started  ]
 netmount                                                          [  started  ]
 sshd                                                              [  started  ]
 xdm                                                               [  started  ]
 local                                                             [  started  ]
Runlevel: sysinit
 sysfs                                                             [  started  ]
 devfs                                                             [  started  ]
 dmesg                                                             [  started  ]
 kmod-static-nodes                                                 [  started  ]
 opentmpfiles-dev                                                  [  started  ]
 udev                                                              [  started  ]
 cgroups                                                           [  started  ]
Runlevel: shutdown
 savecache                                                         [  stopped  ]
 killprocs                                                         [  stopped  ]
 mount-ro                                                          [  stopped  ]
Runlevel: boot
 hwclock                                                           [  started  ]
 swap                                                              [  started  ]
 modules                                                           [  started  ]
 fsck                                                              [  started  ]
 root                                                              [  started  ]
 mtab                                                              [  started  ]
 localmount                                                        [  started  ]
 procfs                                                            [  started  ]
 loopback                                                          [  started  ]
 urandom                                                           [  started  ]
 sysctl                                                            [  started  ]
 binfmt                                                            [  started  ]
 hostname                                                          [  started  ]
 bootmisc                                                          [  started  ]
 termencoding                                                      [  started  ]
 keymaps                                                           [  started  ]
 opentmpfiles-setup                                                [  started  ]
Runlevel: nonetwork
 local                                                             [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                      [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual

 

LXDE starts with lightdm that starts with /etc/conf.d/xdm line 'lightdm'

nm-dispatcher may break lightdm work when it is running lxde, and it stops - I had this event one time. I never had this on slim.

Share this post


Link to post
Share on other sites
  • 0
# epro

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: intel64-silvermont
      flavor: desktop
     mix-ins: lxde


=== Python kit: ===

      branch: 3.4-prime

=== All inherited flavor from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)


# ego kit 
/var/git/meta-repo (updated 1 day 24 hours 57 minutes ago):

  kit                  active branch        default              stability
  core-kit             1.0-prime            (same)               prime
  core-hw-kit          master               (same)               prime
  security-kit         1.0-prime            (same)               prime
  xorg-kit             1.19-prime           (same)               prime
  gnome-kit            3.20-prime           (same)               prime
  kde-kit              5.10-prime           (same)               prime
  media-kit            1.1-prime            (same)               prime
  perl-kit             5.24-prime           (same)               prime
  python-kit           3.4-prime            (same)               prime
  php-kit              master               (same)               prime
  java-kit             1.1-prime            (same)               prime
  ruby-kit             1.1-prime            (same)               prime
  haskell-kit          1.1-prime            (same)               prime
  ml-lang-kit          1.1-prime            (same)               prime
  lisp-scheme-kit      1.1-prime            (same)               prime
  lang-kit             1.1-prime            (same)               prime
  dev-kit              1.1-prime            (same)               prime
  xfce-kit             4.12-prime           (same)               prime
  desktop-kit          1.1-prime            (same)               prime
  editors-kit          master               (same)               prime
  net-kit              master               (same)               prime
  text-kit             master               (same)               prime
  science-kit          master               (same)               prime
  games-kit            master               (same)               prime
  nokit                master               (same)               prime

  NOTE: This information comes from /etc/ego.conf and meta-repo metadata. After
  making changes to ego.conf, be sure to run ego sync in so that the individual
  kit repositories on disk are synchronized with the kit branches shown above.
  

# emerge -pvq @world > https://pastebin.com/YSv27XbG

Share this post


Link to post
Share on other sites
  • 0

ok. you have 2 laptops so one can be for testing stuff and the other one for communicating. is this correct?

if yes,

then stop xdm and remove all logs from /var/log/X.*
 

/etc/init.d/xdm stop

rm /var/log/X.*

then disable networkmanager (it will not fix your situation, I just want to show you that it is NOT networkmanager that is responsible for lightdm not starting on your pc)

rc-update delete NetworkManager

then restart your pc and report back with what you see. and post /var/log/X.0.log (or any other number that is there)

Thank you

Share this post


Link to post
Share on other sites
  • 0

 

# /etc/init.d/xdm stop
 * Stopping lightdm ...
 * start-stop-daemon: no matching processes found                         [ ok ]
# rm /var/log/X.*
rm: невозможно удалить «/var/log/X.*»: No such file or directory
# cd /var/log
# ls
ConsoleKit      dmesg             lightdm           sandbox   xdm.log
Xorg.0.log      emerge-fetch.log  news              slim.log
Xorg.0.log.old  emerge.log        pm-powersave.log  tallylog
cups            lastlog           portage           wtmp
# rm /var/log/Xorg*
# rc-update delete NetworkManager
 * service NetworkManager removed from runlevel default

# reboot

 

Share this post


Link to post
Share on other sites
  • 0

after reboot I saw boot message 'DHCP started' and one more after it. But the next 20 messages about ModemManager, NetworkMnager, netmount disappeared. Afer filling loging form LXDE was shown. But no network.

After adding NetworkManager to rc `rc-update add NetworkManager default` and `reboot` I authorize to lightdm and see the same blackscreen with nm-dispatcher messages. Also during booting I saw connection progress and other 20 messages about ModemManager, NetworkManager, netmount

/var/log/Xorg.0.log -  https://pastebin.com/7QGg1PTG

Can I replace networkmanager's start after login? or may be rearrange?

 

Share this post


Link to post
Share on other sites
  • 0

I've deleted NetworkManager from rc, rebooted, authorized normally and saw LXDE without any problems. I opened terminal: `su`, `NetworkManager`

it started and wifi was connected.

This is not linux way, but one solution is to add NetworkManager to xinit not adding to rc.

But I want linux-way. is it a bug? Do I need netmount if I do not use home network?

Share this post


Link to post
Share on other sites
  • 0

I added start of NetworkManager to system xinitrc.d instead of rc:

# cd /etc/X11/xinit/
# ls
xinitrc  xinitrc.d  xserverrc
# cd xinitrc.d
# ls
00-xhost  40-libcanberra-gtk-module  80-dbus  90-consolekit
# nano 92-networkmanager
# 
# ls -la
итого 28
drwxr-xr-x 2 root root 4096 дек 29 16:45 .
drwxr-xr-x 3 root root 4096 дек 21 06:12 ..
-rwxr-xr-x 1 root root  255 дек 21 06:12 00-xhost
-rwxr-xr-x 1 root root  275 дек 20 19:17 40-libcanberra-gtk-module
-rwxr-xr-x 1 root root  341 дек 24 20:02 80-dbus
-rwxr-xr-x 1 root root 1027 дек 24 21:29 90-consolekit
-rw-r--r-- 1 root root  144 дек 29 16:45 92-networkmanager
# chmod +x 92*
# rc-update
               binfmt | boot                                   
             bootmisc | boot                                   
              cgroups |                                 sysinit
                 dbus |      default                           
                devfs |                                 sysinit
               dhcpcd |      default                           
                dmesg |                                 sysinit
                 fsck | boot                                   
             hostname | boot                                   
              hwclock | boot                                   
              keymaps | boot                                   
            killprocs |                        shutdown        
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork                 
           localmount | boot                                   
             loopback | boot                                   
              modules | boot                                   
             mount-ro |                        shutdown        
                 mtab | boot                                   
             netmount |      default                           
     opentmpfiles-dev |                                 sysinit
   opentmpfiles-setup | boot                                   
               procfs | boot                                   
                 root | boot                                   
            savecache |                        shutdown        
                 sshd |      default                           
                 swap | boot                                   
               sysctl | boot                                   
                sysfs |                                 sysinit
         termencoding | boot                                   
                 udev |                                 sysinit
              urandom | boot                                   
                  xdm |      default 
# reboot  

not helped

Share this post


Link to post
Share on other sites
  • 0

New trying was this:

# pwd
/etc/NetworkManager/dispatcher.d

# ls
10-openrc-status  no-wait.d  pre-down.d  pre-up.d

# cat 10*
#!/bin/sh
# Copyright (c) 2012 Alexandre Rostovtsev
# Released under the 2-clause BSD license.

# Ensures that the NetworkManager OpenRC service is marked as started and
# providing net only when it has a successful connection.

if [ ! -e "/run/openrc/softlevel" ]; then
	# OpenRC is not running
	exit 0
fi

# Ensure rc-service is in PATH
PATH="${PATH}:/sbin:/usr/sbin"

# Exit if the NetworkManager OpenRC service is not running
rc-service NetworkManager status 2>&1 | grep -Eq "status: (starting|started|inactive|stopping)" || exit 0

# Call rc-service in background mode so that the start/stop functions update
# NetworkManager service status to started or inactive instead of actually
# starting or stopping the daemon
export IN_BACKGROUND=YES

case "$2" in
	up) nm-online -t 0 -x &&
		! rc-service NetworkManager status 2>&1 | grep -q started &&
		exec rc-service NetworkManager start ;;
	down) nm-online -t 0 -x ||
		rc-service NetworkManager status 2>&1 | grep -q stopped ||
		exec rc-service NetworkManager stop ;;
	pre-sleep) rc-service NetworkManager status 2>&1 | grep -q stopped ||
		exec rc-service NetworkManager stop ;;
esac
exit 0
# vim: set ts=4:


# mv 10* ~

# ls
no-wait.d  pre-down.d  pre-up.d

# reboot

 

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, znavko said:

After adding NetworkManager to rc `rc-update add NetworkManager default` and `reboot` I authorize to lightdm and see the same blackscreen with nm-dispatcher messages. Also during booting I saw connection progress and other 20 messages about ModemManager, NetworkManager, netmount

can you get to this state, please? So removing NM from xinit and adding it to default and rebooting.

You are saying: "I authorize to lightdm ... " so Xorg does start even with NM enabled?

Share this post


Link to post
Share on other sites
  • 0
Quote

can you get to this state, please? So removing NM from xinit and adding it to default and rebooting.

NetworkManager is in rc-update. I deleted it from xinit.

Quote

You are saying: "I authorize to lightdm ... " so Xorg does start even with NM enabled?

Yes. Problem was transformed by itself: it did allow to start lightdm, but when I authorize I got the blackscreen with nm-dispatcher's 10 messages.

I do not know why but after `rc-udate delete..` and `rc-update add...` nm-dispatcher did allow to start lightdm, but stopped  booting after authorization. And I  needed to start new console with Ctrl + Alt + F4, authorize there and run `lightdm` where I authorize, and LXDE started normally in this console.

 

But now my problem is solved.

Networkmanager is in rc-update. I only do: deleted  /etc/NetworkManager/dispatcher.d/10-openrc-status.

But also I deleted modemmanager from boot as described here https://askubuntu.com/questions/216114/how-can-i-remove-modem-manager-from-boot

 

Can you see bug in /etc/NetworkManager/dispatcher.d/10-openrc-status ?

Share this post


Link to post
Share on other sites
  • 0

No, removing /etc/NetworkManager/dispatcher.d/10-openrc-status did not help. problem appeared again.

It stops on message 'nm-dispatcher: req:4: 'hostname' start running ordered scripts' I need to open new console with ctrl + alt + f4, authorize and run lightdm then authorize again, only after that lxde runs. and tis is what i have after lxde run.

# rc-status --all

Runlevel: default
 dhcpcd                                                            [  started  ]
 dbus                                                              [  started  ]
 NetworkManager                                                    [ inactive  ]
 netmount                                                          [ scheduled ]
 sshd                                                              [  started  ]
 xdm                                                               [  started  ]
 local                                                             [  started  ]
Runlevel: sysinit
 sysfs                                                             [  started  ]
 devfs                                                             [  started  ]
 dmesg                                                             [  started  ]
 kmod-static-nodes                                                 [  started  ]
 opentmpfiles-dev                                                  [  started  ]
 udev                                                              [  started  ]
 cgroups                                                           [  started  ]
Runlevel: shutdown
 savecache                                                         [  stopped  ]
 killprocs                                                         [  stopped  ]
 mount-ro                                                          [  stopped  ]
Runlevel: boot
 hwclock                                                           [  started  ]
 swap                                                              [  started  ]
 modules                                                           [  started  ]
 fsck                                                              [  started  ]
 root                                                              [  started  ]
 mtab                                                              [  started  ]
 localmount                                                        [  started  ]
 procfs                                                            [  started  ]
 loopback                                                          [  started  ]
 urandom                                                           [  started  ]
 sysctl                                                            [  started  ]
 binfmt                                                            [  started  ]
 hostname                                                          [  started  ]
 bootmisc                                                          [  started  ]
 termencoding                                                      [  started  ]
 keymaps                                                           [  started  ]
 opentmpfiles-setup                                                [  started  ]
Runlevel: nonetwork
 local                                                             [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                      [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×