Jump to content
funtoo forums
  • 0
Sign in to follow this  
dhudson

[solved] how to make new kernel-4.14.2-1 default

Question

after reading the docs its not clear to me what it is i need to change in /etc/boot.conf , which is unchanged I think.

the old 4.8.15-1 is default at this point would like to have new one.

i just want to keep the old kernel around a while just in case.

$ cat /etc/boot.conf
boot {
        generate grub
        default "Funtoo Linux" 
        timeout 3 
}

"Funtoo Linux" {
        kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=auto rootfstype=auto
} 

"memtest86+" {
       type linux16
       kernel /memtest86.bin
}
-rw-r--r--  1 root root 3.2M Dec 27 17:41 System.map-debian-sources-x86_64-4.14.2-1
-rw-r--r--  1 root root 3.3M Dec 24  2016 System.map-debian-sources-x86_64-4.8.15-1
-rw-r--r--  1 root root 8.8M Dec 27 19:22 initramfs-debian-sources-x86_64-4.14.2-1
-rw-r--r--  1 root root 7.8M Dec 24  2016 initramfs-debian-sources-x86_64-4.8.15-1
-rw-r--r--  1 root root 4.8M Dec 27 17:41 kernel-debian-sources-x86_64-4.14.2-1
-rw-r--r--  1 root root 4.2M Dec 24  2016 kernel-debian-sources-x86_64-4.8.15-1
-rw-r--r--  1 root root 147K Sep 15 07:54 memtest86.bin

any help appreciated, thanks

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

changing /etc/boot.conf to this should work

boot {
        generate grub
        default "Funtoo Linux genkernel" 
        timeout 3 
}

"Funtoo Linux" {
        kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel-debian-sources-x86_64[-v]
        initrd initramfs-debian-sources-x86_64[-v]
        params += real_root=auto rootfstype=auto
} 

"memtest86+" {
        type linux16
        kernel /memtest86.bin
}

 

Share this post


Link to post
Share on other sites
  • 0
 # boot-update

boot-update 1.8.2 /
Copyright 2009-2017 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

  * Generating config for grub...

  DEFAULT > Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.8.15-1
            Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.14.2-1
            memtest86+

  * NOTE: Detected MBR boot. Configuring for Legacy MBR booting.
  * WARN: No boot/default match found - using first boot entry by default.

  * Completed successfully with warnings.

I would of thought so too but its not the case, thanks

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0

I have never used boot-update, as I always do this manually. But the output says

* WARN: No boot/default match found - using first boot entry by default.

It seems to me that you are missing the line that specifies the default kernel to boot, if more than one kernel is defined, like e.g.

set default=0

is booting the first kernel as default.

 

OK, looking at the page of boot-update I see that you have a defaut setting in place but I think the system detects two kernels named 

"Funtoo Linux genkernel"

and chooses the first one.

Share this post


Link to post
Share on other sites
  • 0

Your very correct, found it in boot.conf manual

If multiple "Funtoo Linux" boot entries are created, the one that has the most recently created kernel (by file mtime) will be booted by default.

Note that double-quotes are optional both in section names and in the boot/default value.

Added the genkernel to default it worked fine.

thanks for pointing that out, I missed it .

Share this post


Link to post
Share on other sites
  • 0

and running boot-update afterwards.

boot-update

boot-update 1.8.2 /
Copyright 2009-2017 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

  * Generating config for grub...

            Funtoo Linux - bzImage-4.9.71-ck
            Funtoo Linux - bzImage
  DEFAULT > Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.14.2-1
            Funtoo Linux genkernel - kernel-debian-sources-x86_64-4.14.1-1
            memtest86+

  * NOTE: Detected UEFI boot. Configuring for UEFI booting.
  * WARN: multiple matches found for default "Funtoo Linux genkernel" - most recent used.
  * NOTE: Intel microcode will be loaded at boot-time.

  * Completed successfully with warnings.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×