Jump to content
funtoo forums
  • 0
Sign in to follow this  
devpump

[Solved] startx No devices detected. [Intel]

Question

Solution: http://forums.funtoo.org/index.php?/topic/140-solved-startx-no-devices-detected-intel/&do=findComment&comment=678

 

Hello Funtoo community,

 

I just recentlly installed Funtoo, but I am unable to get my xorg to properly work. Every time I start I receive "No devices detected." and "no screens found". Is there any easy fix for this? Information/Logs posted below.

 

Current Profiles:

funtoo/1.0/linux-gnu/arch/x86-64bit
funtoo/1.0/linux-gnu/build/current -> Moving from stable today. (8/10/14)
funtoo/1.0/linux-gnu/flavor/desktop -> Moving from stable today. (8/10/14)

lspci | grep -i VGA:

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

 

Installed: x11-drivers/xf86-video-intel, xorg-x11

 

Xorg.0.log: http://pastebin.com/msLVkN9f

 

Kernel Config: http://pastebin.com/4JMtwqQb

 

/etc/X11/xinit/xinitrc.d/10-driver.conf:

Section "Device"
        Identifier "Intel"
        Driver "intel"
EndSection

Thanks in advance for the help.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hello,

 

Did you try Xorg -configure as root and then trying the suggested config file?

Which card do you have? If that doesn't work, I'd go for the appropriate kernel config for your specific card. Given that several cards have a similar name but are from different generations (thus using different modules), I would not rely just in the info given by lspci.

 

Cheers,

 

PeGa!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...