Jump to content
  • 0

OS freezes suddenly


znavko
 Share

Question

Hello! I had a trouble on my laptop Lenovo G50-30 when I used XFCE. Funtoo stopped suddenly without any key or mouse motion I could do. Just last picture and last cursor position shown.

I changed de to LXDE and problem solved.

But I recompiled system with CFLAGS: -O3 a week ago.

I am seeing this problem again now just browsing the web.

I cannot know what is the reason. I typed `emerge lxde-meta lxde-common xorg-x11` and got this https://pastebin.com/R2GmsBZ8

Show me how to catch a bug?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

 

3 hours ago, znavko said:

I am seeing this problem again now just browsing the web.

what problem are you seeing again?

maybe there is something wrong with your hardware if it stops working, maybe there was something wrong with xfce and maybe there is something wrong with lxde. It is hard to tell if you don't provide any context.

Do you have anything in the logs, anything in dmesg ...

I would also suggest you try to run software compiled with "supported" CFLAGS as was already suggested. I don't see any problem with the last emerge lxde-meta lxde-common ... What do you mean:

4 hours ago, znavko said:

I typed `emerge lxde-meta lxde-common xorg-x11` and got this https://pastebin.com/R2GmsBZ8

Why are you compiling your system with -O3? How are you recompiling it? There are just too many variables involved.

Link to comment
Share on other sites

  • 0

# dmesg > https://pastebin.com/jQamF0Ac

Laptop Lenovo had no problems with other linux: debian.

Quote

Do you use nvidia, intel or both drivers?

# lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

# cat /proc/modules  > https://pastebin.com/bLQQSrgG

 

Link to comment
Share on other sites

  • 0
On 12/16/2017 at 10:35 AM, jhan said:

Looking at the specifications of the Lenovo G50-30 it seems to me that this computer also has a dual graphics chipset (Intel/Nvidia), as does mine. If I remember correctly, my graphic problems stopped when I removed th nvidia support and only used intel graphics.

Thank you, @jhan ! According to specification of Lenovo G50-30 it used 2GB DDR3L RAM, but I mounted 4GB DDR3.

It stopped due to RAM crashes. ☺️

Quote

Customer: Do you have any two-watt, 4-volt bulbs?
Sales Rep: For what?
Customer: No, two.
Sales Rep: Two what?
Customer: Yes.
Sales Rep: No.

https://www.powerstream.com/powerhumor.htm

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...