Jump to content
funtoo forums
  • 0
Sandro

[Funtoo stable] Trouble installing "dvdstyler"

Question

Hello everyone. 
Unfortunately trying to install dvdstyler I get the following error (actually the system is "consistent") 
 
ci7ht ~ # emerge -DNu world 
Calculating dependencies ... done! 
Auto-cleaning packages ... >>> 
 
>>> No outdated packages were found on your system. 

ci7ht ~ # emerge -DNu world dvdstyler 
Calculating dependencies ... done! 
 
! Multiple package instances within at single package slot Have Been pulled 
! into the dependency graph, Resulting in a slot conflict: 
 
media-libs / libsdl: 0 
 
   (media-libs / libsdl-1.2.15-r4 :: gentoo, ebuild scheduled for merge) pulled in by 
     (That no parents are not satisfied by other packages in this slot) 
 
   (media-libs / libsdl-1.2.15-r7 :: gentoo, installed) pulled in by 
     >=media-libs/libsdl-1.2.15-r4[sound,video,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-video / ffmpeg-2.2.4 :: gentoo, installed) 
 
 
It may be possible to solve this problem by using package.mask to 
One of Those prevent packages from being selected. However, it is Also 
That possible conflicting dependencies exist longer available That they are 
impossible to Satisfy simultaneously. If a conflict exists longer available in 
the dependencies of two different packages, then Those packages can 
not be installed simultaneously. You may want to try a larger value of 
--backtrack the option, as longer available --backtrack = 30, in order to see if 
That will solve this conflict automatically. 
 
For more information, see MASKED PACKAGES section in the emerge man 
page or the refer to the Gentoo Handbook. 
 
 
emerge: there are no ebuilds to satisfy "> = virtual / libudev-215: =". 
(dependency required by "media-video / dvdstyler-2.7.2 [udev]" [ebuild]) 
(dependency required by "dvdstyler" [argument]) 
 
 
There are not packages That satisfied> = virtual / libudev-215: = 
but: 
 
ci7ht ~ # eix virtual / udev 
[I] virtual / udev 
      Available versions: ~ 0171 ~ 196 197-208-r2 r3 {(+) gudev (+) HWDB introspection keymap + kmod selinux (+) ABI_MIPS static-libs = "n32 n64 o32" ABI_PPC = "32 64" = ABI_S390 "32 64 "ABI_X86 =" 32 64 x32 "} 
      Installed versions: 208-r2 (03:34:47 07/29/2014) (gudev HWDB introspection ABI_MIPS static-libs = "- n32 -n64 -o32" ABI_PPC = "- 32 -64" ABI_S390 = "- 32 -64 "ABI_X86 =" 64 -32 -x32 ") 
      Description: Virtual udev daemon to select between different providers 
 
Any solution?
 
Thanx :)

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...