Jump to content
funtoo forums
  • 0
Philipp Ludwig

Reading a LUKS keyfile from a FAT USB Drive during boot

Question

My laptop is running an encrypted funtoo installation, which prompts me for the password of the root volume during boot. This works nice, but since I'm lazy I'd like to read the key from an USB drive.

Using the commandline parameter root_key=keyfile.bin this works fine if I boot my custom kernel, where support for FAT fileystems is built into the kernel (not as a module).

However, using the debian kernel this does not work, since the initramfs cannot mount the device - I guess because of missing support for the FAT fileysystem. I tried adding fat and vfat to /usr/share/genkernel/defaults in the line MODULES_FS, but without any luck.

Is this even possible or do I need to use something like ext4 on the USB drive?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Thanks for your explanation and ongoing support oleg! I will look into alternative builder for the initramfs and maybe add a guide for the Surface Pro 4 to the Wiki. I will mark this as solved for now.

Edit: Wow, seems that I have made two different accounts. That's embarassing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...