Jump to content
funtoo forums
  • 0
Sandro

[Funtoo Stable] Error compiling games-board/aisleriot-3.2.3.2-r1

Question

Hi to All.

aisleriot doesn't compile.

 

The trouble i think is described in build.log:

checking for perl >= 5.8.1... 5.18.2
checking for XML::Parser... ok
checking which guile version to use... 1.8
configure: error: guile version 1.8 not found. Install it, or use --with-guile to select a different version

But  i've installed the

 

[ebuild   R    ] dev-scheme/guile-2.0.11:12  USE="deprecated networking nls regex threads -debug -debug-malloc -emacs -static"

 

How can i solve ?

 

Thank You :)

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Sandro, I think you could mask '>dev-scheme/guile-1.8' and 'emerge --oneshot' it in the meantime this is fixed.

 

 

You caused it, really? the ebuild seems unmodified from gentoo(I run both funtoo and gentoo, and checked both portage trees), and it would give the same problem I think,ignore me if I'm wrong:

COMMON_DEPEND in '>=dev-scheme/guile-1.8.0:12[deprecated,regex]' wich also is valid for '~guile-2.0' and G2CONF with '--with-guile=1.8'wich causes the build to fail, so wouldn't this be also a bug for gentoo? or was this caused by masks/unmasks in the profiles?

 

This isn't a bug for Gentoo as they don't even have the versions of the slib and guile packages that I introduced into mainline earlier today. In fact, Gentoo has a lot of these packages masked, including >=aisleriot-3.2.

 

Anyway, this issue has been resolved. It will take a couple hours before the change hits mainline though.

Share this post


Link to post
Share on other sites
  • 0

Sandro, I think you could mask '>dev-scheme/guile-1.8' and 'emerge --oneshot' it in the meantime this is fixed.

 

I caused this, sorry. :)

 

I'm working on this now over at FL-1421.

You caused it, really? the ebuild seems unmodified from gentoo(I run both funtoo and gentoo, and checked both portage trees), and it would give the same problem I think,ignore me if I'm wrong:

COMMON_DEPEND in '>=dev-scheme/guile-1.8.0:12[deprecated,regex]' wich also is valid for '~guile-2.0' and G2CONF with '--with-guile=1.8'wich causes the build to fail, so wouldn't this be also a bug for gentoo? or was this caused by masks/unmasks in the profiles?

Share this post


Link to post
Share on other sites
  • 0

I see now, why this doesn't affect gentoo, thanks for the clarification, anyway it feels wrong for me the fact that ebuild has a depend on another package saying it wants a greater-or-equal version, when later it wants to use only one version, but I'm still trying to learn about ebuilds, and what's right and wrong in them, so maybe that's why I don't get this particular one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...