Jump to content
funtoo forums
  • 0
Sign in to follow this  
Ciges

Instal of old version of MySQL 5.5.57 impossible due to libmysqlclient

Question

Hello,

 

I am trying to install an old version of MySQL, the 5.5.57 version and I get the following portage error:

 

Calculating dependencies... done!
[ebuild  N     ] dev-db/mysql-init-scripts-2.2-r1 
[ebuild  N     ] dev-perl/Net-Daemon-0.480.0-r1 
[ebuild  N     ] virtual/perl-Sys-Syslog-0.330.0-r6 
[ebuild  N     ] dev-perl/PlRPC-0.202.0-r2 
[ebuild  N     ] dev-perl/DBI-1.636.0  USE="-examples {-test}" 
[ebuild  N    #] dev-db/mysql-5.6.37  USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] virtual/libmysqlclient-18  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-perl/DBD-mysql-4.41.0  USE="ssl -embedded {-test}" 
[ebuild  N    #] virtual/mysql-5.6-r9  USE="server -embedded -static" 
[ebuild  N     ] dev-db/mysql-5.5.57  USE="community perl ssl -bindist (-cluster) -debug -embedded -extraengine -jemalloc -latin1 -max-idx-128 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test}" 
[ebuild  N     ] virtual/mysql-5.5-r1  USE="-embedded -minimal -static -static-libs" 


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


dev-db/mysql:0


  (dev-db/mysql-5.5.57:0/18::dev-kit, ebuild scheduled for merge) pulled in by
    =dev-db/mysql-5.5.57 (Argument)
    =dev-db/mysql-5.5*[embedded=,minimal=,static=,static-libs=] required by (virtual/mysql-5.5-r1:0/0::nokit, ebuild scheduled for merge)
    ^             ^^^^                                                                                                                                                                          


  (dev-db/mysql-5.6.37:0/18::dev-kit, ebuild scheduled for merge) pulled in by
    dev-db/mysql:0/18[client-libs(+),static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (virtual/libmysqlclient-18:0/18::nokit, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                  
    =dev-db/mysql-5.6*[embedded?,server?,static?] required by (virtual/mysql-5.6-r9:0/18::nokit, ebuild scheduled for merge)
    ^             ^^^^                                                                                                                                                             


virtual/mysql:0


  (virtual/mysql-5.6-r9:0/18::nokit, ebuild scheduled for merge) pulled in by
    =virtual/mysql-5.6-r9[embedded=,static=] required by (dev-db/mysql-5.6.37:0/18::dev-kit, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                                      
    (and 1 more with the same problem)


  (virtual/mysql-5.5-r1:0/0::nokit, ebuild scheduled for merge) pulled in by
    =virtual/mysql-5.5-r1 required by (dev-db/mysql-5.5.57:0/18::dev-kit, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                   
    (and 1 more with the same problem)

I have masked some packages to prevent installation of newer versions 

 

>dev-db/mysql-5.5.57
dev-db/mysql-connector-c
dev-db/mariadb
>=virtual/mysql-5.6
dev-db/percona-server
dev-db/mariadb-galera
dev-db/mysql-cluster
 
Apparently the libmysqlclient package wants MySQL 5.6 version to be installed and I don't understand why as 5.5 is compatible with 18 client library version as is shown by eix package information
 
* dev-db/mysql [1]
     Available versions:  (~)5.5.57(0/18)^d [m]5.6.35(0/18)^t [m]5.6.36(0/18)^t [m]5.6.37(0/18)^t {bindist cluster +community debug embedded extraengine jemalloc latin1 libressl max-idx-128 minimal +openssl +perl profiling selinux +server ssl static static-libs systemtap tcmalloc test yassl ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            http://www.mysql.com/
     Description:         A fast, multi-threaded, multi-user SQL database server

Could anyone give me a clue of how to install MySQL 5.5.57?

 

 

Thanks in advance

 
 
 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi , I'm not 100% sure but I think its telling you , you can not have both at the same time.

so do a emerge --depclean mysql -a to see what its going to remove then answer y if you want it.

then you should be able to proceed with your 5.5 install.

 

notice 5.5.57 has been marked unstable for some reason.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×