Jump to content
funtoo forums

Ciges

Members
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by Ciges

  1. Hi Is there a way to tell portage that a package is already installed? I would like that a package from a dependency not to be installed and the easiest way could be to "pretend" it is already in the system. Any idea?
  2. Hello, I am trying to install an old version of MySQL, the 5.5.57 version and I get the following portage error: Calculating dependencies... done! [ebuild N ] dev-db/mysql-init-scripts-2.2-r1 [ebuild N ] dev-perl/Net-Daemon-0.480.0-r1 [ebuild N ] virtual/perl-Sys-Syslog-0.330.0-r6 [ebuild N ] dev-perl/PlRPC-0.202.0-r2 [ebuild N ] dev-perl/DBI-1.636.0 USE="-examples {-test}" [ebuild N #] dev-db/mysql-5.6.37 USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" ABI_X86="(64) -32 (-x32)" [ebuild N ] virtual/libmysqlclient-18 USE="-static-libs" ABI_X86="(64) -32 (-x32)" [ebuild N ] dev-perl/DBD-mysql-4.41.0 USE="ssl -embedded {-test}" [ebuild N #] virtual/mysql-5.6-r9 USE="server -embedded -static" [ebuild N ] dev-db/mysql-5.5.57 USE="community perl ssl -bindist (-cluster) -debug -embedded -extraengine -jemalloc -latin1 -max-idx-128 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test}" [ebuild N ] virtual/mysql-5.5-r1 USE="-embedded -minimal -static -static-libs" !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-db/mysql:0 (dev-db/mysql-5.5.57:0/18::dev-kit, ebuild scheduled for merge) pulled in by =dev-db/mysql-5.5.57 (Argument) =dev-db/mysql-5.5*[embedded=,minimal=,static=,static-libs=] required by (virtual/mysql-5.5-r1:0/0::nokit, ebuild scheduled for merge) ^ ^^^^ (dev-db/mysql-5.6.37:0/18::dev-kit, ebuild scheduled for merge) pulled in by dev-db/mysql:0/18[client-libs(+),static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (virtual/libmysqlclient-18:0/18::nokit, ebuild scheduled for merge) =dev-db/mysql-5.6*[embedded?,server?,static?] required by (virtual/mysql-5.6-r9:0/18::nokit, ebuild scheduled for merge) ^ ^^^^ virtual/mysql:0 (virtual/mysql-5.6-r9:0/18::nokit, ebuild scheduled for merge) pulled in by =virtual/mysql-5.6-r9[embedded=,static=] required by (dev-db/mysql-5.6.37:0/18::dev-kit, ebuild scheduled for merge) ^ ^^^^^^ (and 1 more with the same problem) (virtual/mysql-5.5-r1:0/0::nokit, ebuild scheduled for merge) pulled in by =virtual/mysql-5.5-r1 required by (dev-db/mysql-5.5.57:0/18::dev-kit, ebuild scheduled for merge) ^ ^^^^^^ (and 1 more with the same problem) I have masked some packages to prevent installation of newer versions >dev-db/mysql-5.5.57 dev-db/mysql-connector-c dev-db/mariadb >=virtual/mysql-5.6 dev-db/percona-server dev-db/mariadb-galera dev-db/mysql-cluster Apparently the libmysqlclient package wants MySQL 5.6 version to be installed and I don't understand why as 5.5 is compatible with 18 client library version as is shown by eix package information * dev-db/mysql [1] Available versions: (~)5.5.57(0/18)^d [m]5.6.35(0/18)^t [m]5.6.36(0/18)^t [m]5.6.37(0/18)^t {bindist cluster +community debug embedded extraengine jemalloc latin1 libressl max-idx-128 minimal +openssl +perl profiling selinux +server ssl static static-libs systemtap tcmalloc test yassl ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"} Homepage: http://www.mysql.com/ Description: A fast, multi-threaded, multi-user SQL database server Could anyone give me a clue of how to install MySQL 5.5.57? Thanks in advance
×
×
  • Create New...