Jump to content
funtoo forums
  • 0
znavko

Xorg modules fail while update world

Question

Hello! I am so happy to use Funtoo on Lenovo G50-30. It increases performance. I hope you will help me to solve one trouble after world update.

Some x11-proto packages was not emerged and I have blinking windows when use terminal and XFCE4 dialog windows.

 

system:

# uname -a
Linux localhost.localdomain 4.8.15-1 #1 SMP Mon Jul 24 15:58:06 -00 2017 x86_64 Intel(R) Pentium(R) CPU N3530 @ 2.16GHz GenuineIntel GNU/Linux
#gcc -v
???????????? ?????????? ????????????.
COLLECT_GCC=/usr/x86_64-pc-linux-gnu/gcc-bin/5.3.0/gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-pc-linux-gnu/5.3.0/lto-wrapper
??????? ???????????: x86_64-pc-linux-gnu
????????? ????????????: ../gcc-5.3.0/configure --disable-libssp --disable-multilib --enable-version-specific-runtime-libs --enable-libmudflap --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/5.3.0 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/5.3.0/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.3.0/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/5.3.0/include/g++-v5.3.0 --enable-libstdcxx-time --enable-__cxa_atexit --enable-clocale=gnu --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --with-system-zlib --enable-obsolete --disable-werror --enable-secureplt --enable-lto --without-cloog --with-bugurl=http://bugs.funtoo.org --with-pkgversion='Funtoo 5.3.0-r1' --with-mpfr-include=/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/gcc-5.3.0/mpfr/src --with-mpfr-lib=/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir/mpfr/src/.libs --enable-libgomp --build=x86_64-pc-linux-gnu --enable-libgomp --enable-languages=c,c++,fortran --disable-libgcj --disable-esp --disable-libsanitizer
?????? ???????????????: posix
gcc ?????? 5.3.0 (Funtoo 5.3.0-r1)
# cat /etc/portage/make.conf
MAKEOPTS="-j5"
LINGUAS="en_US ru_RU"
L10N="en-US ru-RU"

CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"

CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

VIDEO_CARDS="intel"

USE="alsa dbus core-kit flv introspection
     jpeg mp3 networkamager nsplugin  
     ppapi png
     udev policykit
     X zlib
     -gnome -gtk -kde -qt3 -qt4
     -wicd"

PYTHON_TARGETS="python2_7 python3_4"
PYTHON_SINGLE_TARGET="python3_4"

my script for update:

# cat re.sh
emerge --sync
eix-update

emerge -avuND --with-bdeps=y --complete-graph=y --backtrack=30 --keep-going --verbose-conflicts --exclude "chromium gentoo-sources gimp glibc libreoffice perl python gcc" world

x11-proto/xextproto-7.3.0, x11-proto/fixesproto-5.0-r1, x11-proto/inputproto-2.3.2, x11-proto/kbproto-1.0.7 and other proto packages was missed.

 

Here it is randrproto build and config log:

 

https://pastebin.com/y45FDbiQ

 

Please let me know how to bypass these errors?

 

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I tried to install chromium and this is why I changed gcc version to 5.3.0. Today I tried to `emerge gcc` and got the errors.

`tail -n 100 /var/tmp/portage/sys-devel/gcc-5.3.0-r1/temp/build.log`

https://pastebin.com/4Ytn0LPp

`emerge --info '=sys-devel/gcc-5.3.0-r1::core-kit'`

https://pastebin.com/prhHc1f6

/usr/include/gnu/stubs.h:7:27: fatal error: gnu/stubs-32.h: No such file or directory
compilation terminated.
Makefile:878: recipe for target '_gcov_merge_single.o' failed
make[5]: *** [_gcov_merge_single.o] Error 1
make[5]: Leaving directory '/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir/x86_64-pc-linux-gnu/32/libgcc'
Makefile:1154: recipe for target 'multi-do' failed
make[4]: *** [multi-do] Error 1
make[4]: Leaving directory '/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir/x86_64-pc-linux-gnu/libgcc'
Makefile:117: recipe for target 'all-multi' failed
make[3]: *** [all-multi] Error 2
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir/x86_64-pc-linux-gnu/libgcc'
Makefile:17188: recipe for target 'all-stage1-target-libgcc' failed
make[2]: *** [all-stage1-target-libgcc] Error 2
make[2]: Leaving directory '/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir'
Makefile:21422: recipe for target 'stage1-bubble' failed
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory '/var/tmp/portage/sys-devel/gcc-5.3.0-r1/work/objdir'
Makefile:21801: recipe for target 'bootstrap-lean' failed
make: *** [bootstrap-lean] Error 2

 

Share this post


Link to post
Share on other sites
  • 0

# epro show-json
{
"mix-ins": [
{
"shortname": "xfce",
"path": "/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/mix-ins/xfce"
}
],
"flavor": [
{
"shortname": "desktop",
"path": "/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/flavor/desktop"
}
],
"arch": [
{
"shortname": "x86-64bit",
"path": "/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit"
}
],
"build": [
{
"shortname": "current",
"path": "/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/build/current"
}
],
"subarch": [
{
"shortname": "intel64-silvermont-pure64",
"path": "/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/arch/pure64/subarch/intel64-silvermont-pure64"
}
]
}

Share this post


Link to post
Share on other sites
  • 0

so, the reason of failing is that your toolchain (gcc, glibc, binutils)  built without multilib support but your profile is multilib, did you by chance disabled it? maybe you installed from pure64 stage and then changed profile? to fix this you might resurrect your toolchain packages from stage3 (make sure it's multilib, i.e do not use pure64 for that), follow this guide:

http://www.funtoo.org/System_resurrection

tbz2 way will work for you, so get the fresh new stage, mount it somewhere, prepare bin packages for glibc, gcc, binutils, linux-headers and then extract into your system as described.

Share this post


Link to post
Share on other sites
  • 0

You are right: I choose pure64 but after I tried to install LibreOffice, Gimp and other packages, I changed profile to 'desktop' following the advise from the Internet.

 

Now I booted with systemrescuecd, created dir /mnt/fresh, downloaded intel-64 silvermont stage3 current, and extracted to /mnt/fresh.

I cannot certainly understand what is "prepare bin packages". Should I chroot to /mnt/fresh, run `ego sync` to get meta-repo and then emerge listed packages? If so how then extract into my system? I've read http://www.funtoo.org/System_resurrection, the 'Tbz2 Extract Method' describes untar commands, but I do not know where to download gcc, glibc,binutils and search does not help me: http://www.funtoo.org/index.php?title=Special%3AMultiSearch&query=glibc

 

Please, what to do?

Share this post


Link to post
Share on other sites
  • 0

Not sure about your current problem but you can run a pure64 system and desktop, see:

=== Enabled Profiles: ===

        arch: pure64
       build: current
     subarch: (not set)
      flavor: desktop
     mix-ins: hardened

Share this post


Link to post
Share on other sites
  • 0

I booted with systemrescuecd, untar stage3 to my funtoo root path, rebooted to funtoo and the black screen carried away everything.

Now I am installing funtoo again using 'stage3 current standard' variant.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×