Jump to content
funtoo forums
  • 0
Sandro

cpupower and 4.12.X kernel

Question

Dearest, I know the service "cpupower" with the kernel


ci4771ht ~ # uname -a
Linux ci4771ht 4.12.5-gentoo # 1 SMP PREEMPT Fri Sep 1 23:40:33 CEST 2017 x86_64 Intel (R) Core i7-4771 CPU @ 3.50GHz GenuineIntel GNU / Linux

mistake me, that is:


cpupower | * Running cpupower -c all frequency-set --governor ondemand ... [!! ]
cpupower | * ERROR: cpupower failed to start

 

I would like to have some explanation, if perhaps cpupower is "deprecated" or how to configure kernel (with previous version everything worked perfectly).

 

Thanx for any suggestion.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I haven't used cpupower but looking at the man page and the output of 'cpupower help' I see no argument '--governor'. 

 

What are your parameters for starting cpupower?

Share this post


Link to post
Share on other sites
  • 0
rc-update add cpupower default

Then i ask about frequency using in a terminal

watch cpupower frequency-info

cause

ci74771ht ~ # /etc/init.d/cpupower start
cpupower           | * Caching service dependencies ...                                          [ ok ]
cpupower           | * Running cpupower -c all frequency-set --governor ondemand ...             [ !! ]
cpupower           | * ERROR: cpupower failed to start

my kernel is

Linux ci74771ht 4.12.5-gentoo #1 SMP PREEMPT Tue Sep 5 00:07:21 -00 2017 x86_64 Intel(R) Core(TM) i7-4771 CPU @ 3.50GHz GenuineIntel GNU/Linux

with older versions of kernel, i don't had enabled the Intel P-state.

now with this kernel is enabled by default an is not possible to change it.. (excuse my bad US lang :|

thanx for the aid :)

Share this post


Link to post
Share on other sites
  • 0

Hard to tell without any real error message. Does 'dmesg' show any errors? Have you tried a newer kernel version?

 

What is the output of 'cpupower frequency-info'? How does your '/etc/conf.d/cpupower' look like?

 

As far as I know you can disable P-state with the kernel option "intel_pstate=disable". Look at https://stackoverflow.com/questions/23526671/how-to-solve-the-cpufreqset-errors for more info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×