Jump to content
funtoo forums
Sign in to follow this  
erikr

Storry: My Near Windows 10 Experience

Recommended Posts

Hi,

 

I have just had an near windows experience I'd like to share.

 

Earlier this year I purchased a new Dell laptop. It had Windows 7 professional installed and offered a licence (not depending on free upgrade) also valid for Windows 10 pro.

 

Naturally I installed what I always install; Gentoo or Funtoo, and in this case Funtoo. Beside the few commands I need to enter it mostly just works. Mainly because I make decisions along the way and in the end I reach goal. For this particular laptop I had struggle with fully utilizing the Skylake CPU fully out (se my other thread about that), but I also had problems with sleep function that rebooted computer on wakeup. Using a kernel config from Sabayone solve that (but don't ask me what actually made the trick).

 

Then I decided to fire off a new company and that a company needs at least one Windows 10 computer. I decided to use the laptop. It has a window 10 licence, windows 10 have virtuakl desktops and I can always install the Ubuntu stuff to get a bash and awk running.

That decided I installed Windows 10 but strangely it failed to activate. I tried the Dell reset DVD that failed to install and thought that it will solve it self somehow when in contact  with M$$$ and went on with installing my stuff during weekend.

 

 

So I called M$$$ on monday that told me to call Dell. So I called Dell and that told me to download another reset image (6.5 GB!) that failed 4 times before I did the download from Windows that used a helper program and then failed to install. In several calls the only advice was to reinstall the computer to get the key activated but after some calls Dell decided to replace the motherboard. So they did today and I got a nice little CD-cover with a Window licence key in it. Swell. Reinstall the computer and enter the licence key and it activates Windows. Nice. Upgrade. Reboot. What the F... Windows no longer activated. New calls with Dell that help out a while but aske me to call M$$. M$$$ refused to help unless I created a blXXdy microsoft account. Given the number of privacy options I had to turn off during install and the number still not deactivated I refused so they refused to help me. Still no M$$$ key that works.

 

When I complained to my Wife she asked me the obvious question. What do you need Windows for?  And she is right. Love to her!

 

Two hours later I have read back the BTRFS snapps I sent to the server as backups. Then it took me 5 minutes to reload /boot and reinstall grub on the hard drive. Reboot and things just work.

 

I did dismiss usage of Windows in any of my home computers when my Windows XP got infected by Genuine Advantage. A few moth later I was in love with Gentoo. Now, after all this time, when I decide to actually make use of the commercial windows using a real license that have been paid for it fails to activate. My intention to use paid software is hindered by the protection against piracy, what an irony.

 

I have asked the dell staff to record that I will come back to solve the license issue another time. Three days in phone is enough for now. Funtoo back in place and the calm inside is back - I am able to fix things that breaks and make things work MY way.

 

// Erik

 

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×