Jump to content
funtoo forums
  • 0
Sign in to follow this  
dougbmorris

Ideas to Stop Suspend/Hibernate on Lid Close?

Question

GOAL:
I am hoping someone can give me an idea on what I can change or investigate to solve a new behavior problem with my laptop.
 
ISSUE:
I have a Sony Vaio laptop that boots from Grub Legacy to Funtoo (usually) or to Windows 7 (rarely). I have this new behavior of suspension or hibernation when I close my laptop lid. The solid green lighting associated with the power button becomes flashing orange. I have to create a device input signal (I typically press a modifier key of the keyboard) to get it to wake up, then in a few seconds the screen goes black, the suspension is on again, and soon the flashing orange will resume. I provide user input a second time and then I have control over my laptop again, until I close the lid with the thing on. The suspend or hibernation (not sure which, never did work right on purpose) stops portage from updating my @world, etc. Annoying. I have the laptop plugged in to good AC power.
 
CIRCUMSTANCES:
This new behavior started after I used Windows 7 about 5 days ago and let some updates run for a day until I shut it off, cleanly I think, with a normal shutdown from the start button menu, but not only after that. More lately I've made changes/updates with portage to my Funtoo. I checked the BIOS settings on boot up and see nothing that could account for new behavior or control it. It should be the case, I think, that the new behavior in Funtoo with lid closing has nothing to do with Windows updates on other partitions of the same internal laptop HD.
 
FAILED APPROACHES:
(1) I tried downgrading and I tried removing app-laptop/laptop-mode-tools. I rebooted to be sure. No change.
(2) There is nothing in the H20 BIOS to set differently.
(3) I tried booting with my older vanilla-sources kernels. No change.
(4) Using xfce4. Nothing to set with the setting manager that will fix this, as far as I know. Under Power Manager I switched from 'Lock screen' on close to simply 'Switch off display' on close. No change in problem.
 
I can't think of anything else to try except letting Sony Vaio software continue updating my computer with Windows 7. No telling how long that would take after all these years. I have no idea what in Funtoo I can downgrade that might resolve this issue.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The problem was package sys-power/acpid-2.0.28. I rolled back from that to sys-power/acpid-2.0.23 based on reading Oleg Vinichenko's help on the issue "GNOME: no power manager utility or lid close trigger" for speedytux. Maybe this link will work still: http://forums.funtoo.org/topic/1036-gnome-no-power-manager-utility-or-lid-close-trigger/ . At least know for the first time that my suspend function works. The hibernate function just turns off my laptop faster than normal. I guess that's how it didn't work right when I first installed funtoo. Cheers.

Share this post


Link to post
Share on other sites
  • 0

I put this out into the ether. I tried the latest acpid today, which is acpid-2.0.28-r1, on 10 January 2017. Just like plain acpid-2.0.28, its revision one triggers a Funtoo Gnu/Linux suspension on my Sony VAIO laptop on lid close. I never had the suspend actually work before, so there's the silver lining. Still, I only get correct behavior with acpid-2.0.23. Is there a better choice than acpid?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...