Jump to content

Photo

CUPS browsing not working

- - - - -

5 replies to this topic

#1
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

I just replaced a Debian desktop in my home with Funtoo.  The Debian desktop shared a printer with the rest of the network.  The printer was seen by my Funtoo laptop.  Since I replaced the Debian desktop with Funtoo, my laptop can no longer see the printer that is shared -- even if I use the same cupsd.conf file from the Debian system.

 

I have researched this a bit and based on various advice on the internet I've enabled the zeroconf use flag for cups on both systems.  I tried installing nss-mdns (and edited /etc/nsswitch.conf as suggested).  I've made sure that both avahi-daemon and avahi-dnsconfd are running (even though I'm not 100% sure this is necessary).  So far nothing has worked.

 

Does anybody have this working?  Could you share your configuration with me?

 

As I said, this worked when my Debian system was sharing the printers, so I don't expect to need to make any changes on the Funtoo laptop.  But just in case, I have temporarily turned off the firewall.  There is no firewall on the desktop system.



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 224 posts

There should be some way to determine if avahi is broadcasting.



#3
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Is it definitely avahi that does the broadcasting?  Or are there other methods that can be used?

 

cupsd.conf had 'BrowseLocalProtocols' -- not sure if that's legitimate or not.  I tried changing to 'BrowseLocalProtocols all' but didn't see any improvement.



#4
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 224 posts

zeroconf flag enables avahi with cups and cups-filters
Start by verifying avahi is running and port 5353 is open.
These outputs are from an old ubuntu install that runs avahi.

rj@intrepid:~$ pgrep avahi
2624
2625

rj@intrepid:~$ sudo nmap -sU -p 5353 localhost

Starting Nmap 4.76 ( http://nmap.org ) at 2016-03-26 12:59 EDT
Interesting ports on localhost (127.0.0.1):
PORT     STATE         SERVICE
5353/udp open|filtered zeroconf

Nmap done: 1 IP address (1 host up) scanned in 2.32 seconds

According to these instructions cups needs dbus and avahi needs mdnsresponder-compat enabled .

I would enable dbus for cups-filter which was likely split off from cups after the instructions were written in 2012.



#5
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Thanks Cardinal.  I've got it working now.  I'm going to start backing out all the changes I made so I can figure out which of the many changes I made were necessary.  I will post back.



#6
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Turns out it was only working very intermittently.  I fixed the problem by getting rid of avahi.  Cups browsing worked without it, and it turned out avahi was the source of my troubles.  I will post my configuration once I get the chance (I don't have access to the systems in question at the moment).





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users