Jump to content

Photo

Is it possible to avoid abi_x86_32 on a 64-bit desktop?

- - - - -

1 reply to this topic

#1
paddymac

paddymac

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

I can understand why certain binary packages which are only available in 32-bit versions would require 32-bit versions of libraries to be installed as dependencies. What I don't really understand is why 32-bit dependencies still get pulled in when all the software I have installed is compiled from source. Is it possible to avoid 32-bit software completely? It's not that I mind having 32-bit software installed. The problem I have is that sometimes what happens is that a single 32-bit program in turn may require many other programs to also be compiled as 32-bit, so it seems like an endless chain of dependencies having to be recompiled as 32-bit. Are there some ebuilds which default to having abi_x86_32 enabled? Is this possibly why 32-bit dependencies are inevitably pulled in?



#2
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 339 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

You've select "pure64" in your profiles ?

# epro list

And in make.conf must be set 

ABI_X86="64"

then take a look to "emerge --info" and to /etc/portage/package.use if is enabled some abi_32 variable.

 

However, i've a multilib system and the space for lib32 is:

sandro@ci74771ht ~ $ du -hs /lib32/
5,8M    /lib32/

Then a very little space on the disk :)





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users