Jump to content

Photo

UEFI hangs

UEFI Hangs Black screen Blank screen Grub hangs Boot Grub EFI

Best Answer buyinsurance , 14 July 2014 - 06:20 AM

Thanks for your reply. nomodeset didn't work for me. Your advice was helpful and I made sure my settings were right, so thank you for that :).

 

Unfortunately, it still didn't work. So I decided to try something different.

 

I ended up finding a fix! I'm now able to boot in correctly. I believe this is a fix for someone that's exhausted all possible kernel trials. I'm assuming this is a funtoo grub packaging problem or something was wrong with my grub.cfg. It's just weird because grub was loading fine, that is why I assumed kernel error.

 

Here is what I did to fix it:

  1. emerge --unmerge grub
  2. Added a local overlay, something like /usr/local/portage is good.
  3. Added gentoo's version of grub to the overlay. It was also a newer version than funtoo's.
  4. emerge -va grub
  5. grub-install --target=x86_64-efi --efi-directory=/boot /dev/sda
  6. grub2-mkconfig -o /boot/grub/grub.cfg
  7. Restarted and was able to get into my system.

If anyone has any idea why the funtoo grub didn't work for me, let me know.

Go to the full post »


5 replies to this topic

#1
buyinsurance

buyinsurance

    Newbie

  • Members
  • Pip
  • 3 posts

Hello,
 
I followed this guide for setting up UEFI: http://www.funtoo.or...I_Install_Guide

 

After I select an option from GRUB the screen just goes black. I have SSH server on for testing and the system never goes up.

 

I have tried with both the debian binary kernel and a custom kernel. I also haven't ran an emerge -auDN world (maybe this is my problem), as I'd imagine it shouldn't matter if Xorg radeon drivers are installed to get to a shell.

 

Here is the config for the custom kernel I tried.

Spoiler

 

Here is my make.conf

Spoiler

 

And my grub.cfg

Spoiler

 

Any ideas? My video card is an R9 270x if that helps :).

 

Thanks.



#2
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts

I had a similar problem a few months ago, since you are able to see the grub menu and select an option, that's working fine, and since you don't seem to be getting to init, I don't think the @world upgrade is relevant, have you tried booting with the nomodeset flag on the kernel command line?

 

I didn't look at your kernel config but my problem was in the video drivers, In the framebuffer ones, I activated the framebuffer for efi, and my video card, also the generic one, they didn't play nice all at boot, and after some search i found out, I pretty much just wanted the xorg driver for my video card, so I disabled the kernel ones, this might be your case.



#3
buyinsurance

buyinsurance

    Newbie

  • Members
  • Pip
  • 3 posts
✓  Best Answer

Thanks for your reply. nomodeset didn't work for me. Your advice was helpful and I made sure my settings were right, so thank you for that :).

 

Unfortunately, it still didn't work. So I decided to try something different.

 

I ended up finding a fix! I'm now able to boot in correctly. I believe this is a fix for someone that's exhausted all possible kernel trials. I'm assuming this is a funtoo grub packaging problem or something was wrong with my grub.cfg. It's just weird because grub was loading fine, that is why I assumed kernel error.

 

Here is what I did to fix it:

  1. emerge --unmerge grub
  2. Added a local overlay, something like /usr/local/portage is good.
  3. Added gentoo's version of grub to the overlay. It was also a newer version than funtoo's.
  4. emerge -va grub
  5. grub-install --target=x86_64-efi --efi-directory=/boot /dev/sda
  6. grub2-mkconfig -o /boot/grub/grub.cfg
  7. Restarted and was able to get into my system.

If anyone has any idea why the funtoo grub didn't work for me, let me know.


  • drobbins and cuchumino like this

#4
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts

Good you solved your problem, I think this is a bug in Funtoo, you should report it, I did my instalation of grub kinda like you, and usually update my configs manually(grub-mkconfig desn't do what I want), and  I didn't use the funtoo boot scripts, so I can't confirm this.(Or maybe after all, it might be solved after a @world upgrade)



#5
buyinsurance

buyinsurance

    Newbie

  • Members
  • Pip
  • 3 posts

Now that my @world is updated, I'll see if I can find some time by the weekend to retry funtoo's grub with my new autogenerated grub config and my old manually made config.



#6
cuchumino

cuchumino

    Member

  • Members
  • PipPip
  • 28 posts

Hello Guys,

 

I just bought a laptop, and am trying to get UEFI to boot correctly. I keep hanging in a black screen, and to be quite honest, would like to  keep away from overlaying anything outside the "boot-updater" way.

 

I'm going to try to just use legacy booting for now, but will update if I have any success in the future with UEFI booting.

 

Edit : I think this bug might have something to do with it. I'll use the overlay method, once this but is fixed however, I'll use the proper funtoo method. :)

 

Edit 2: I can confirm using the gentoo grub worked for me as well. I just had to add the initrd line to my grub.conf, which was missing. Once I have a graphical windows manager, I'll reference the full line just to be clear. Thanks!


Edited by cuchumino, 21 July 2014 - 10:20 PM.




Reply to this topic



  



Also tagged with one or more of these keywords: UEFI, Hangs, Black screen, Blank screen, Grub hangs, Boot, Grub, EFI

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users