Jump to content
funtoo forums

buyinsurance

Members
  • Content Count

    3
  • Joined

  • Last visited

  • Days Won

    2

buyinsurance last won the day on July 21 2014

buyinsurance had the most liked content!

About buyinsurance

  • Rank
    Newbie
  1. Now that my @world is updated, I'll see if I can find some time by the weekend to retry funtoo's grub with my new autogenerated grub config and my old manually made config.
  2. Thanks for your reply. nomodeset didn't work for me. Your advice was helpful and I made sure my settings were right, so thank you for that :). Unfortunately, it still didn't work. So I decided to try something different. I ended up finding a fix! I'm now able to boot in correctly. I believe this is a fix for someone that's exhausted all possible kernel trials. I'm assuming this is a funtoo grub packaging problem or something was wrong with my grub.cfg. It's just weird because grub was loading fine, that is why I assumed kernel error. Here is what I did to fix it: emerge --unmerge grub Added a local overlay, something like /usr/local/portage is good. Added gentoo's version of grub to the overlay. It was also a newer version than funtoo's. emerge -va grub grub-install --target=x86_64-efi --efi-directory=/boot /dev/sda grub2-mkconfig -o /boot/grub/grub.cfg Restarted and was able to get into my system. If anyone has any idea why the funtoo grub didn't work for me, let me know.
  3. Hello, I followed this guide for setting up UEFI: http://www.funtoo.org/UEFI_Install_Guide After I select an option from GRUB the screen just goes black. I have SSH server on for testing and the system never goes up. I have tried with both the debian binary kernel and a custom kernel. I also haven't ran an emerge -auDN world (maybe this is my problem), as I'd imagine it shouldn't matter if Xorg radeon drivers are installed to get to a shell. Here is the config for the custom kernel I tried. Here is my make.conf And my grub.cfg Any ideas? My video card is an R9 270x if that helps :). Thanks.
×
×
  • Create New...