Jump to content
funtoo forums
  • 0
Sign in to follow this  
stamasd

Can't start X as a regular user

Question

Continuing the install from my other thread; I managed to get the base system installed, followed by Xorg, the radeon driver (I have a Radeon HD7970 in this desktop) and xfce.

 

Everything works well as root, but well I'm not going to use it as root. Trying to start X as a regular user gives me this:

 

 

xauth:  file /home/silviu/.serverauth.15013 does not exist


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.19.3-1~exp1 x86_64 Gentoo
Current Operating System: Linux dfun 3.19.3-1~exp1 #1 SMP Mon Oct 19 12:04:59 2015 x86_64
Kernel command line: BOOT_IMAGE=/kernel-debian-sources-x86_64-3.19.3-1~exp1 rootfstype=auto real_root=/dev/sda6 rootfstype=ext4
Build Date: 19 December 2015  05:09:20PM
 
Current version of pixman: 0.33.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 20 16:41:51 2015
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
gbm: failed to open any driver (search paths /usr/lib64/dri)
gbm: Last dlopen error: /usr/lib64/dri/radeonsi_dri.so: cannot open shared object file: No such file or directory
failed to load driver: radeonsi
EGL_MESA_drm_image required.
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
xinit: connection to X server lost

waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file.

 

It looks for some reason for /usr/lib64/dri/radeonsi_dri.so which indeed does not exist.

 

Why does it work as root but not as regular user?

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I looked and looked, but I can't find documentation on the group 'video' or any documentation on a list of groups with descriptions. Rather maddening. This possible solution will at least be easy to try.

 

List your groups with the command: groups

 

Maybe one of them is 'video'. If not, maybe you need to make that group, but I am not sure.

 

List the members of the video group: groupmems -lg video

 

If the username w/o root privileges is not there, maybe it needs to be there?

 

To add to test  it out: groupmems -g video -a <username>

 

For further info, if you did not know, try running 'dmesg' and also 'less /var/log/Xorg.0.log'.

Share this post


Link to post
Share on other sites
  • 0

If you're trying to stat plain X, you must install twm, xterm, and xclock. If you're not trying to start plain X, edit /etc/init.d/xdm and put your preferred display mananger in there.

 

The error about radeonsi_dri.so could be that you don't have that file. Did you enable the radeon use flag when compiling Mesa? Do you have VIDEO_CARDS="radeon" in /etc/portage/make.conf ?

Share this post


Link to post
Share on other sites
  • 0

If you're trying to stat plain X, you must install twm, xterm, and xclock. If you're not trying to start plain X, edit /etc/init.d/xdm and put your preferred display mananger in there.

 

The error about radeonsi_dri.so could be that you don't have that file. Did you enable the radeon use flag when compiling Mesa? Do you have VIDEO_CARDS="radeon" in /etc/portage/make.conf ?

 

I am not trying to start plain X. I have installed xfce4-meta, and my .xinitrc is (for both root and regular user)

exec startxfce4 --with-ck-launch

I also do have in /etc/portage/make.conf:

VIDEO_CARDS="radeon"
INPUT_DEVICES="evdev"

I don't use a display manager, just plain xfce. I think if it were a mesa issue it wouldn't work as root either.

 

Like I said it works as root (xfce starts and runs as it should), but it crashes as regular user.

Share this post


Link to post
Share on other sites
  • 0

I looked and looked, but I can't find documentation on the group 'video' or any documentation on a list of groups with descriptions. Rather maddening. This possible solution will at least be easy to try.

 

List your groups with the command: groups

 

Maybe one of them is 'video'. If not, maybe you need to make that group, but I am not sure.

 

List the members of the video group: groupmems -lg video

 

If the username w/o root privileges is not there, maybe it needs to be there?

 

To add to test  it out: groupmems -g video -a <username>

 

For further info, if you did not know, try running 'dmesg' and also 'less /var/log/Xorg.0.log'.

dfun ~ # groups
root bin daemon sys adm disk wheel floppy tape video
dfun ~ # groupmems -lg video
root
dfun ~ # groupmems -g video -a silviu
dfun ~ # groupmems -lg video
root  silviu

Let me test and see if that helped.

 

(edit) no, it still gives me the same error. IIRC the "video" group is for encoding and capturing video, not for X.

 

 

FWIW here's my list of profiles:

dfun ~ # epro

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: generic_64
      flavor: desktop
     mix-ins: X
     mix-ins: xfce
     mix-ins: no-systemd
     mix-ins: print
     mix-ins: audio
     mix-ins: dvd
     mix-ins: media


=== All inherited flavors from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

=== All inherited mix-ins from media mix-in: ===

      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)

Share this post


Link to post
Share on other sites
  • 0

So I'm still testing. I have added "radeonsi" to make.conf VIDEO_CARDS, and tried a emerge; it now wants some USE changes as such:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/mesa-11.0.7::gentoo[video_cards_radeonsi]
# required by x11-base/xorg-server-1.16.4-r5::gentoo[glamor]
# required by @selected
# required by @world (argument)
>=x11-libs/libdrm-2.4.65 video_cards_amdgpu
# required by net-misc/modemmanager-1.4.8::gentoo[policykit]
# required by net-misc/networkmanager-1.0.8::gentoo[modemmanager]
# required by @selected
# required by @world (argument)
>=sys-auth/polkit-0.113 introspection
# required by media-libs/mesa-11.0.7::gentoo[llvm,-opencl,-video_cards_r600,video_cards_radeon,video_cards_radeonsi]
# required by x11-base/xorg-server-1.16.4-r5::gentoo[glamor]
# required by @selected
# required by @world (argument)
>=dev-libs/elfutils-0.164 abi_x86_32

I'm adding those and retry, maybe that will do it. Now waiting to emerge 42 packages.

 

(I found some post on a Gentoo forum about cards >radeon HD7900 wanting the "radeonsi" driver in addition to "radeon")

I still don't get it why X+xfce works as root though.

Share this post


Link to post
Share on other sites
  • 0

Well, it still doesn't work. The line about not finding the radeonsi driver is gone, but X still doesn't start.

xauth:  file /home/silviu/.serverauth.3699 does not exist


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.19.3-1~exp1 x86_64 Gentoo
Current Operating System: Linux dfun 3.19.3-1~exp1 #1 SMP Mon Oct 19 12:04:59 2015 x86_64
Kernel command line: BOOT_IMAGE=/kernel-debian-sources-x86_64-3.19.3-1~exp1 rootfstype=auto real_root=/dev/sda6 rootfstype=ext4
Build Date: 19 December 2015  05:09:20PM
 
Current version of pixman: 0.33.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec 21 08:18:10 2015
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
xinit: connection to X server lost

waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file.

Again, I have .xinitrc set to start xfce, but it doesn't seem that it tries to do that for some reason.

 

I'm out of ideas, and appeal to the collective knowledge of this forum.

Share this post


Link to post
Share on other sites
  • 0

Oh my. I am so embarrassed. I have found the error - it was a typo. My clue was what I said above ".xinitrc set to start xfce, but it doesn't seem that it tries to do that for some reason"

 

So, I checked and... there it was. Instead of .xinitrc, I had named the file .xinit (for thr regular user only, root had .xinitrc named properly)

 

I fixed that, and now it works. The radeonsi driver was just a red herring.

 

Sorry for wasting everyone's time, mark this as "solved". :)

Share this post


Link to post
Share on other sites
  • 0

Funtoo and Gentoo are among the Linux distributions that are hardest to use. I wouldn't beat yourself about it if I were you. 

 

The pursuit of knowledge is not a waste of time, and on that road we all make mistakes. Mistakes is perhaps what we learn most from, so it's not all bad.   :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×