Jump to content
  • 0

installing wine


adcdam
 Share

Question

hi, after emerge wine and i get this i dont know what to do

 

 

 

 

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] dev-lang/spidermonkey-1.8.5-r4  USE="-debug -minimal -static-libs {-test}"
[ebuild  N     ] virtual/eject-0
[ebuild   R    ] dev-libs/elfutils-0.163  USE="static-libs*"
[ebuild  N     ] media-libs/libv4l-1.6.2  USE="jpeg" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] sys-block/parted-3.2  USE="debug nls readline -device-mapper (-selinux) -static-libs"
[ebuild  N     ] sys-devel/prelink-20130503  USE="(-selinux)"
[ebuild  N     ] sys-auth/polkit-0.113  USE="gtk nls pam -examples -introspection -jit -kde (-selinux) -systemd {-test}"
[ebuild  N     ] gnome-extra/polkit-gnome-0.105-r1
[ebuild  N     ] sys-auth/consolekit-0.4.6  USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}"
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs"
[ebuild  N     ] dev-libs/libgudev-230  USE="-debug -introspection -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] virtual/libgudev-230  USE="-introspection -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] sys-fs/udisks-2.1.6  USE="gptfdisk -cryptsetup -debug -introspection (-selinux) -systemd"
[ebuild  N     ] app-emulation/wine-1.7.51  USE="X alsa cups fontconfig gecko jpeg lcms mono mp3 ncurses nls opengl perl png prelink realtime run-exes ssl threads truetype udisks v4l xcomposite xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -ldap -netapi -odbc -openal -opencl -osmesa -oss -pcap -pipelight -pulseaudio -s3tc -samba -scanner (-selinux) -staging {-test} -vaapi -xinerama" ABI_X86="32 (64) (-x32)" LINGUAS="es -ar -bg -ca -cs -da -de -el -en -en_US -eo -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"
[blocks B      ] sys-fs/eudev[gudev(-)] ("sys-fs/eudev[gudev(-)]" is blocking dev-libs/libgudev-230)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libgudev-230::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libgudev:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,introspection?,static-libs?] (dev-libs/libgudev:0/0[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libgudev-230::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-1.5.3-r2::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.3 required by (virtual/udev-215::gentoo, installed)
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-),abi_x86_64(-),static-libs] required by (virtual/libudev-215::gentoo, installed)
    sys-fs/eudev required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/prelink-20130503
# required by app-emulation/wine-1.7.51[prelink]
# required by wine (argument)
>=dev-libs/elfutils-0.163 static-libs
# required by sys-auth/polkit-0.113[-systemd]
# required by gnome-extra/polkit-gnome-0.105-r1
=sys-auth/consolekit-0.4.6 policykit

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi i edited /etc/portage/package.use file and added sys-fs/eudev -gudev to the file

then i did sudo emerge wine -D -N and i got this:

 

i dont know what to to now.

 


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-exec-2.0.2  PYTHON_TARGETS="(python3_5%*)" 
[ebuild  N     ] dev-util/re2c-0.14.3 
[ebuild   R    ] sys-libs/readline-6.3_p8-r2  USE="-utils%" 
[ebuild     U  ] sys-apps/coreutils-8.24 [8.23] USE="-multicall%" 
[ebuild  rR    ] sys-devel/bc-1.06.95-r2 
[ebuild     UD ] dev-libs/icu-55.1 [55.1-r1001]
[ebuild     U  ] x11-libs/libdrm-2.4.65 [2.4.61] VIDEO_CARDS="-amdgpu%" 
[ebuild     U  ] dev-libs/libgcrypt-1.6.3-r5 [1.6.3-r1] USE="threads%* -doc%" 
[ebuild     U  ] net-misc/curl-7.45.0 [7.43.0] CURL_SSL="-libressl%" 
[ebuild     UD ] media-libs/fontconfig-2.11.1-r2 [2.11.94]
[ebuild     UD ] dev-libs/libxml2-2.9.2-r1 [2.9.2-r1001] PYTHON_TARGETS="python2_7%* python3_3%* -python3_4% -python3_5%" 
[ebuild  N     ] dev-util/ninja-1.6.0  USE="-doc -emacs {-test} -vim-syntax -zsh-completion" 
[ebuild     U  ] dev-python/packaging-15.3-r2 [15.2] PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -pypy3% -python3_4% -python3_5%" 
[ebuild  N     ] dev-lang/spidermonkey-1.8.5-r4  USE="-debug -minimal -static-libs {-test}" 
[ebuild     UD ] dev-libs/libxslt-1.1.28-r4 [1.1.28-r1002] PYTHON_TARGETS="python2_7%*" 
[ebuild     U  ] dev-python/setuptools-18.4 [17.1.1-r1000] PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -pypy3% -python3_4% -python3_5%" 
[ebuild     U  ] dev-python/certifi-2015.9.6.2 [14.05.14-r1000] PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -pypy3% -python3_4% -python3_5%" 
[ebuild     U  ] sys-libs/cracklib-2.9.6 [2.9.4-r1000] PYTHON_TARGETS="python2_7%*" 
[ebuild  N     ] virtual/eject-0 
[ebuild   R    ] virtual/udev-215  USE="-systemd%" 
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs" 
[ebuild     U  ] dev-libs/elfutils-0.164 [0.163] USE="static-libs*" 
[ebuild  N     ] media-libs/libv4l-1.6.2  USE="jpeg" ABI_X86="32 (64) (-x32)" 
[ebuild  N     ] sys-block/parted-3.2-r1  USE="debug nls readline -device-mapper (-selinux) -static-libs" 
[ebuild  N     ] sys-devel/prelink-20130503  USE="(-selinux)" 
[ebuild   R    ] dev-libs/libcroco-0.6.8-r1  ABI_X86="32*" 
[ebuild     U  ] app-accessibility/at-spi2-core-2.16.0 [2.14.1]
[ebuild  N     ] dev-libs/libgudev-230  USE="-debug -introspection -static-libs" ABI_X86="32 (64) (-x32)" 
[ebuild  N     ] virtual/libgudev-230  USE="-introspection -static-libs" ABI_X86="32 (64) (-x32)" 
[ebuild     U  ] net-print/cups-2.0.4 [2.0.3] PYTHON_TARGETS="python2_7%*" 
[ebuild  N     ] sys-auth/polkit-0.113  USE="gtk nls pam -examples -introspection -jit -kde (-selinux) -systemd {-test}" 
[ebuild  N     ] gnome-extra/polkit-gnome-0.105-r1 
[ebuild  N     ] sys-auth/consolekit-0.4.6  USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}" 
[ebuild  N     ] sys-fs/udisks-2.1.6  USE="gptfdisk -cryptsetup -debug -introspection (-selinux) -systemd" 
[ebuild  r  U  ] sys-devel/llvm-3.7.0-r2 [3.6.2] USE="-lldb%" 
[ebuild  r  U  ] media-libs/mesa-11.0.4 [10.5.2]
[blocks b      ] >=sys-devel/llvm-3.7 (">=sys-devel/llvm-3.7" is blocking media-libs/mesa-10.5.2)
[ebuild     U  ] media-libs/harfbuzz-0.9.41 [0.9.35] USE="-fontconfig%" 
[ebuild  N     ] app-emulation/wine-1.7.51  USE="X alsa cups fontconfig gecko jpeg lcms mono mp3 ncurses nls opengl perl png prelink realtime run-exes ssl threads truetype udisks v4l xcomposite xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -ldap -netapi -odbc -openal -opencl -osmesa -oss -pcap -pipelight -pulseaudio -s3tc -samba -scanner (-selinux) -staging {-test} -vaapi -xinerama" ABI_X86="32 (64) (-x32)" LINGUAS="es -ar -bg -ca -cs -da -de -el -en -en_US -eo -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/prelink-20130503
# required by app-emulation/wine-1.7.51[prelink]
# required by wine (argument)
>=dev-libs/elfutils-0.164 static-libs
# required by sys-auth/polkit-0.113[-systemd]
# required by sys-fs/udisks-2.1.6
# required by app-emulation/wine-1.7.51[udisks]
# required by wine (argument)
=sys-auth/consolekit-0.4.6 policykit

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 

Link to comment
Share on other sites

  • 0

adding this to /etc/portage/package.use?   

dev-libs/elfutils static-libs
sys-auth/consolekit policykit

do i need the package policykit? i dont have that package installed and i would install it if it is absolutely necessary

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...