Jump to content
  • 0

cdm strange behaviour


adcdam
 Share

Question

i installed cdm for display manager, but when funtoo finish booting it goes to the login shell i type my user and password then it load cdm i have to type my user and password again to go to bspwm tilling windows, how can i correct this? and only type my user and password only one time? 

 

 

here is my /etc/cdmrc file

 

#!/bin/bash
#
# Example config file for cdm(1).
# Values set here is the default as in cdm(1).

# List of programs, commands with whitespaces should be quoted or escaped.
# If unset, all sessions in /etc/X11/Sessions or /usr/share/xsessions are
# offered as choices.
#
# (An example:)
# binlist=(
#   '~/.xsession'                    # Launch your X session,
#   '/bin/bash --login'              # or just execute your shell,
#   '/usr/bin/fbterm'                # or start a frame buffer console,
#   '/usr/bin/cdm ~/.submenu.cdmrc'  # or go to a submenu :)
# )

# List all program display names, one-by-one matched with $binlist.
# Names with whitespaces should be quoted or escaped.
#
# (Continued example:)
# namelist=('X session' Console FBTerm 'Sub menu')

# Type of the programs, one-by-one matched with $binlist.
# `C' for *C*onsole programs, which would be `exec'ed.
# `X' for *X* programs, which would be run with cdm-xlaunch(1).
#
# (Continued example:)
# flaglist=(X C C C)

# Style for the cdm dialog, which is printed with dialog(1).
# Default to unset, causing dialog(1) to use the system wide default.
# See /usr/share/doc/cdm/themes for some nice choices.
dialogrc=/usr/share/cdm/themes/cdm

# Index of the first item in the menu.
countfrom=0

 

# Set default display.
display=0

# Where should the first X tty be spawned?
# special value `keep' causes to run X in current tty.
xtty=2

# Should cdm(1) stick to the specified display?
locktty=no

# Use ConsoleKit for X session?
consolekit=no

# Timeout for waiting for X session to register with ConsoleKi$
cktimeout=30

# Additional arguments to pass to X server, which is usually c$
#   /usr/bin/X :$display "${serverargs[@]}" vt$((xtty+display))
# Arguments with whitespaces should be quoted or escaped.
serverargs=(-nolisten tcp)

# Alternative method of calling startx(/setsid). Should only b$
# does not start X as expected (bash -x shows call to setsid s$
# no apparent reason does not start X).
# Only provided in the hope it may be useful, not a guaranteed$
altstartx=no

# Destination for stdout and stderr output from startx.
startxlog=/dev/null
 

 

here is /etcconf.d/xdm

 

# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="cdm"

Thanks!!

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...