Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

Can't use my my favorite music programs in new install




I have just succeeded, with much help from the friends in Discord to finish a new install  from

 stage3-intel64-westmere-next-2023-07-11.tar.xz, and got XFCE, firefox-bin, VLC,, Openshot, OBS-Studio,AbiWord, Libreoffice, Pulse and pavu, and several other to start nicely.

I have not yet tested how some of them - which i use seldom - are functioning,  but overall its feeling good.

One thing though is keeping me from using Funtoo as the main distro in this multiboot (all my machines are multiboot as a matter of principle) machine, and that is   the programs i use the most, like Audacity, Rosegarden and MuseScore.  Qsynth also, but at least fluidsynth is available. and QjackCtl, but that is not an absolute need.

 I had thought of filling a bug report, but I wonder whether I would have to fill a long list of Bug reports, which would take considerably much time from an inveterate and and not so efficient (yet quite content) distro-hopper constantlly struggling with updatings and forum consultations.

So I am asking for advice here first, and in order to make things simpler, I am presenting the problems in code format, gathered today immediately after running:

# ego sync
# emerge -uaDN @world 

As below:

xiaHP ~ # emerge -a audacity

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=media-libs/libsoundtouch-1.3.1".
(dependency required by "media-sound/audacity-2.3.3::media-kit[soundtouch]" [ebuild])
(dependency required by "audacity" [argument])


xiaHP ~ # emerge --search  MuseScore
[ Results for search key : MuseScore ]

[ Applications found : 0 ]

I tried MuseScore's App+Image but it never started, even after I chmod+x it

xiaHP ~ # emerge --search  rosegarden
[ Results for search key : rosegarden ]

*  media-sound/rosegarden
      Latest version available: 23.06
      Latest version installed: [ Not Installed ]
      Size of files: 7,602 KiB
      Homepage:      https://www.rosegardenmusic.com/
      Description:   MIDI and audio sequencer and notation editor
      License:       GPL-2

[ Applications found : 1 ]

xiaHP ~ # emerge -a  rosegarden

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=media-libs/dssi-1.0.0:=".
(dependency required by "media-sound/rosegarden-23.06::media-kit" [ebuild])
(dependency required by "rosegarden" [argument])
xiaHP ~ # emerge --search qsynth
[ Results for search key : qsynth ]

[ Applications found : 0 ]
xiaHP ~ # emerge --search qjackctl
[ Results for search key : qjackctl ]

[ Applications found : 0 ]


Some info on my setup:

 ~ # inxi -ACJ
  Info: dual core model: Intel Core i5 M 560 bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1465 min/max: 1199/2667 cores: 1: 1199 2: 1199 3: 1199
    4: 2266
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    driver: snd_hda_intel
  Device-2: DigiTech Lexicon Alpha driver: snd-usb-audio type: USB
  API: ALSA v: k6.3.11_p1-debian-sources status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active (root, process)
  Hub-1: 1-0:1 info: full speed or root hub ports: 3 rev: 2.0
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
  Device-1: 1-1.1:8 info: DigiTech Lexicon Alpha type: audio rev: 1.1
  Hub-3: 2-0:1 info: full speed or root hub ports: 3 rev: 2.0
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
  Device-1: 2-1.5:3 info: Chicony HP Webcam [2 MP Macro] type: video
    rev: 2.0

uname -a
Linux xiaHP 6.3.11_p1-debian-sources #1 SMP PREEMPT_DYNAMIC Mon Aug 14 06:52:16 CEST 2023 x86_64 GNU/Linux

In my searching I have not found any references to these problems, which I have also noticed in at least another machine I have been working on at the same time (may provide info on that too).

I have though noticed that Funtoo is not the only one having problem with these applications. Some of them are also present in some of my other distros (Slackware, Artix, Void).  With the exception of Void which I have started to use much later   than the  others, all worked great, and some still do in older installs in my older Core Duo desktop, where I am affraid to update Funtoo as Audacity is still installed, although not starting, something I will be taking in another thread here, or Discord, or a bug-report.

As funtoo is in itself working great so far I will continue to use it often in my everyday, using another machine when doing music. Strangely enough the last few weeks I have been using my music stuff mostly Audacity simultaneously with Rosegarden, in an older CoreDuo with 2GB ram and it is just fine.

Edited by fredmyra
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...