Jump to content

[solved] Problems with GNOME (X-Server) in VirtualBox


sabaton
 Share

Recommended Posts

Hello, everyone,

I installed Funtoo as a guest system in VirtualBox.

I have the Funtoo installation according to the instructions https://www.funtoo.org/Install/Introduction

:	
ego profile mix-in +gfxcard-vmware

so far through.
I'm working through GNOME following the guide https://www.funtoo.org/GNOME_First_Steps#A_few_finishing_touches.

root # emerge -auDN @world
root # emerge gnome

root # rm /etc/motd

/etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="gdm"

root # rc-update add dbus default
root # rc-update add elogind default

root # reboot

root # /etc/init.d/xdm start

Unfortunately I only have a black window with a blinking cursor!

Think
/etc/portage/make.conf

USE="initramfs"

MAKEOPTS="-j6"

VIDEO_CARDS="vmware"

INPUT_DEVICES="libinput"

LINGUAS="de en"
L10N="de en"

/var/log/Xorg.0.log https://bpa.st/GJPA

/var/log/dmesg http://bpa.st/XVJA

After startx: /var/log/Xorg.0.log http://bpa.st/CBWA

 

Sorry for my bad English, my mother tongue is German.

How can I get the problem solved?

Kind regards,
Sabaton

Edited by sabaton
Link to comment
Share on other sites

  • sabaton changed the title to [solved] Problems with GNOME (X-Server) in VirtualBox

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...