Jump to content
  • 0

Steam flatpak install


Go to solution Solved by oberon,

Question

I swear that I had Steam working via flatpak for a short while.  It stopped working so I removed everything and started over.  No luck.

When I run the app this is what I get.

>> flatpak -v run com.valvesoftware.Steam
F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/nrc/.local/share/flatpak
F: Opening user flatpak installation at path /home/nrc/.local/share/flatpak
F: Opening user flatpak installation at path /home/nrc/.local/share/flatpak
F: Unknown feature type per-app-dev-shm
F: Cleaning up unused container id 832053680
F: Allocated instance id 1835788086
F: Add defaults in dir /com/valvesoftware/Steam/
F: Add locks in dir /com/valvesoftware/Steam/
F: Xdg dir xdg-music is $HOME (i.e. disabled), ignoring
F: Allowing wayland access
F: Allowing x11 access
F: Allowing pulseaudio access
F: Pulseaudio user configuration file '/home/nrc/.config/pulse/client.conf': Error opening file /home/nrc/.config/pulse/client.conf: No such file or directory
F: Failed to run in transient scope: No systemd user session available, cgroups not available
F: Running '/usr/libexec/flatpak-bwrap --args 36 /usr/libexec/flatpak-dbus-proxy --args=38'
F: Running '/usr/libexec/flatpak-bwrap --args 36 steam-wrapper'
INFO:root:https://github.com/flathub/com.valvesoftware.Steam/wiki
INFO:root:Will set XDG dirs prefix to /home/nrc
INFO:root:Overriding TZ to EST5EDT
Running Steam on org.freedesktop.platform 20.08.9.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
WARNING: Using default/fallback debugger launch
/home/nrc/.local/share/Steam/ubuntu12_32/steam

.local/share/Steam doesn't exist.   If that's supposed to be created during the 'flatpak install' it's not.

I thought maybe I had broken this by running the install part as root at some point but I can't find any ownership or permissions that would seem to block the install and there are not complaints during install.

Suggestions?

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Solution
Posted (edited)

Your steam installation in Flatpak should have a bin_steam.sh in /../com.valvesoftware.Steam/current/active/files/lib/steam. Also a bootstrap.....tar.xz file.

The script unpacks the bootstrap file in a .local/share/Steam directory. The bin_steam.sh script tells you where it installs around line 95:

function install_bootstrap()
{
        STEAMDIR="$1"

        # Save the umask and set strong permissions
        omask="$(umask)"
        umask 0077

        echo $"Setting up Steam content in $STEAMDIR"

 

Towards the end of the script there is the function check_bootstrap(), which checks that the bootstrap was unpacked successfully. Basically you can manually unpack the bootstrap file in the right place:

tar -xf bootstrap.tar.xz and remove the checks in the script and it should execute and run.

 

Make sure that the partition that has the bootstrap etc ($STEAMDIR) is mounted with the exec permission in /etc/fstab !

That's it - voila, it should run now....

Edited by oberon
Link to post
Share on other sites
  • 0

Thanks.  Problem was that that it was failing to extract the tarball.  Not clear why.  Manually extracting the tarball allowed everything to start normally.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...