Jump to content
  • 0
Sign in to follow this  
tbuck713

Chroot issues also

Question

Good afternoon, it has been awhile since i've run anything gentoo, and having aquired 2 thinkpads, windows absolutely had to go.

I began the install by installing the systemrescue cd on a mmc flashcard, and boots the machine up nice and quick. Upon reading the funtoo installation pages, i realized i have a Uefi boot Thinkpad. its a 4th gen 11e with an AMD processor. Everything went as anticipated until it bacame time to chroot into the system.

This was and has been my return error since my initial attempt;

[root@sysresccd /mnt/funtoo]# env -i HOME=/root TERM=$TERM /bin/chroot . bash -l
Illegal instruction (core dumped)

 

I've rebooted twice thinking i missed a command somewhere in the instructions. The tarball i grabbed was gnome 1.4 current out of the AMD-excavator Subarch, and followed the funtoo chroot instructions from creating file systems Chap 5 thru 9 chrooting into the enviroment and nothing, Then i attempted the gentoo way from their handbook before having to ask and find out where i went wrong ... this was my last attempt last nite.

 

[root@sysresccd ~]# lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0 620.1M  1 loop /run/archiso/sfs/airootfs
sda      8:0    0 111.8G  0 disk
├─sda1   8:1    0   500M  0 part
├─sda2   8:2    0     8G  0 part
└─sda3   8:3    0 103.3G  0 part
sdb      8:16   1  61.9G  0 disk
└─sdb1   8:17   1  61.9G  0 part /run/archiso/bootmnt
[root@sysresccd ~]# swapon
[root@sysresccd ~]# mkfs.ext4 /dev/sda3
mke2fs 1.45.6 (20-Mar-2020)
/dev/sda3 contains a ext4 file system
    last mounted on /mnt/funtoo on Sat May 16 15:00:10 2020
Proceed anyway? (y,N) N

[root@sysresccd ~]# date
Sat 16 May 2020 08:09:20 PM UTC
[root@sysresccd ~]# mount /dev/sda3 /mnt/funtoo
mount: /mnt/funtoo: mount point does not exist.
[root@sysresccd ~]# mkdir /mnt/funtoo
[root@sysresccd ~]# mount /dev/sda3 /mnt/funtoo
[root@sysresccd ~]# mkdir /mnt/funtoo/boot
mkdir: cannot create directory ‘/mnt/funtoo/boot’: File exists
[root@sysresccd ~]# mount /dev/sda1 /mnt/funtoo/boot
[root@sysresccd ~]# hwclock --systohc
[root@sysresccd ~]# cd /mnt/funtoo
[root@sysresccd /mnt/funtoo]# ls
bin   dev  gnome-latest.tar.xz  lib    lost+found  mnt  proc  run   sys  usr
boot  etc  home                 lib64  media       opt  root  sbin  tmp  var
[root@sysresccd /mnt/funtoo]# mount --types proc /proc /mnt/funtoo/proc
[root@sysresccd /mnt/funtoo]# mount --rbind /sys /mnt/funtoo/sys
[root@sysresccd /mnt/funtoo]# mount --rbind /dev /mnt/funtoo/dev
[root@sysresccd /mnt/funtoo]# cp /etc/resolv.conf /mnt/funtoo/etc/
[root@sysresccd /mnt/funtoo]# env -i HOME=/root TERM=$TERM /bin/chroot . bash -l
Illegal instruction (core dumped)
[root@sysresccd /mnt/funtoo]# chroot /mnt/funtoo /bin/bash
Illegal instruction (core dumped)
[root@sysresccd /mnt/funtoo]# which chroot
/usr/bin/chroot
[root@sysresccd /mnt/funtoo]# env -i HOME=/root TERM=$TERM /usr/bin/chroot . bash -l
Illegal instruction (core dumped)
[root@sysresccd /mnt/funtoo]#

 

I'm at the wall, what did miss ... before this last attempt using gentoo handbook i'd tried to burn the area31 live cd image to another usb stick, but it wont boot on the 11e or the x131e  I'd try to install it with.

Regards in Advance

Tom

 

EDIT: Wrong subarch i believe 😑

 

 

Edited by tbuck713
update

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

For the Funtoo live image make sure that you're using the version downloaded from the funtoo.org site.  The 'file' utility should report it as having a DOS/MBR partition and not just and ISO-9660 file system.  The ISO-9660 image that Area31 creates won't boot from a USB drive on some systems.

# file funtoo-livecd-area31-5.1-beta-r1.iso 
funtoo-livecd-area31-5.1-beta-r1.iso: DOS/MBR boot sector; partition 1 : ID=0x17, active, start-CHS (0x0,0,1), end-CHS (0x3ff,63,32), startsector 0, 3217408 sectors

 

Share this post


Link to post
Share on other sites
  • 0

Ok so here we are... i grabbed the funtoo live image from the funtoo.org site, and have successfully installed and broken my new system a few times haha

some minor questions i have, upon issuing these commands

chroot # ego sync
chroot # emerge -auDN @world

and having a fresh new world, there are a couple of cleanup commands presented and wanted to clarify. should i run the emerge --depclean before the 1st boot.

Also, for libtool ... after compiling and installing libtool its recommends the command libtool --finish,

am i pointing this at /usr/lib or /usr/lib64?

Share this post


Link to post
Share on other sites
  • 0

On --depclean, it doesn't really matter.  It just cleans up packages that weren't explicitly installed or required by something that was.  So it's a cleanup process to keep things tidy.

On libtool, I've never seen that recommended, but usually on a x86-64bit system /usr/lib is a symlink to /usr/lib64.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...