Jump to content
  • 0
hick518

slot conflicts while upgrading to 1.4

Question

I've upgraded 3 systems from 1.3 to 1.4, and each one has caused me major headaches.  I'm on my fourth one now, and figured it's time to ask for help.

I'm following the instructions here, and I'm up to the point of upgrading python:

https://www.funtoo.org/Upgrade_Instructions/1.4-release

# emerge -u =dev-lang/python-3.7*                                                                                                                                                           
Connected to xxxxxxxxx                                                                                                                                                         
Fetching /packages/Packages to /tmp/tmprupi7h74                                                                                                                                                   
/packages/Packages                            100% 1839KB 226.0KB/s   00:08                                                                                                                       
Calculating dependencies... done!                                                                                                                                                                 
[binary     U  ] app-arch/bzip2-1.0.8 [1.0.6-r9] USE="-abi_riscv_lp64% -abi_risc                                                                                                                v_lp64d% -split-usr%"                                                                                                                                                                           
[binary     U  ] sys-libs/readline-8.0 [7.0_p5] USE="-abi_riscv_lp64% -abi_riscv                                                                                                                _lp64d%"                                                                                                                                                                                        
[binary  NS    ] dev-lang/python-3.7.3 [2.7.15, 3.6.8]                                                                                                                                          

!!! Multiple package instances within a single package slot have been pulled                                                                                                                      
!!! into the dependency graph, resulting in a slot conflict:                                                                                                                                      

sys-libs/readline:0                                                                                                                                         

  (sys-libs/readline-8.0:0/8::core-kit, binary scheduled for merge) pulled in by                                                                                                                
    >=sys-libs/readline-4.1:0/8= required by (dev-lang/python-3.7.3:3.7/3.7m::py                                                                                                                thon-kit, binary scheduled for merge)                                                                                                                                                             
                           ^^^^^                                                                                                                                                                                                                                                                                                                                                                    

  (sys-libs/readline-7.0_p5:0/7::core-kit, installed) pulled in by                                                                                                                              
    sys-libs/readline:0/7= required by (net-dns/bind-tools-9.12.2_p2-r1:0/0::cor                                                                                                                  e-kit, installed)                                                                                                                                                                               
                     ^^^^^                                                                                                                                                                                                                                                                                                                                                                          
    sys-libs/readline:0/7= required by (app-crypt/gnupg-2.2.11:0/0::core-kit, in                                                                                                                  stalled)                                                                                                        
                     ^^^^^                                                                                                                                                                                                                                                                                                                                                                          
    sys-libs/readline:0/7= required by (net-wireless/bluez-5.50-r1:0/3::core-kit                                                                                                                  , installed)                                                                                                                    
                     ^^^^^                                                                                                                                                                                                                                                                                                                                                                          
    >=sys-libs/readline-4.1:0/7= required by (dev-lang/python-3.6.8:3.6/3.6m::py                                                                                                                thon-kit, installed)                                                                                                                                                                            
                           ^^^^^                                                                                                                                                                                                                                                                                                                                                                    
    >=sys-libs/readline-4.1:0/7= required by (net-misc/ntp-4.2.8_p12:0/0::core-k                                                                                                                it, installed)                                                                                                                                                                                  
                           ^^^^^                                                                                                                                                                                                                                                                                                                                                                    
    sys-libs/readline:0/7= required by (sys-apps/util-linux-2.33:0/0::core-kit,                                                                                                                   installed)                                                                                                              
                     ^^^^^                                                                                                                                                                                                                                                                                                                                                                          
    sys-libs/readline:0/7= required by (net-fs/samba-4.9.2-r1:0/0::core-server-k                                                                                                                  it, installed)                                                                                                                                                                                  
                     ^^^^^                                                                                                                                                                                             ^^^^^
    sys-libs/readline:0/7= required by (net-wireless/bluez-5.50-r1:0/3::core-kit, installed)
                     ^^^^^
    >=sys-libs/readline-4.1:0/7= required by (dev-lang/python-3.6.8:3.6/3.6m::python-kit, installed)
                           ^^^^^
    >=sys-libs/readline-4.1:0/7= required by (net-misc/ntp-4.2.8_p12:0/0::core-kit, installed)
                           ^^^^^
    sys-libs/readline:0/7= required by (sys-apps/util-linux-2.33:0/0::core-kit, installed)
                     ^^^^^
    sys-libs/readline:0/7= required by (net-fs/samba-4.9.2-r1:0/0::core-server-kit, installed)
                     ^^^^^
    (and 14 more with the same problems)

app-arch/bzip2:0

  (app-arch/bzip2-1.0.8:0/1::core-kit, binary scheduled for merge) pulled in by
    app-arch/bzip2:0/1= required by (dev-lang/python-3.7.3:3.7/3.7m::python-kit, binary scheduled for merge)
                  ^^^^^

  (app-arch/bzip2-1.0.6-r9:0/0::core-kit, installed) pulled in by
    app-arch/bzip2:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::python-kit, installed)
                  ^^^^^
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (net-wireless/bluez-5.50-r1:0/3::core-kit, installed): ebuild is masked or unavailable
  (net-fs/samba-4.9.2-r1:0/0::core-server-kit, installed): ebuild is masked or unavailable
  (sys-apps/util-linux-2.33:0/0::core-kit, installed): ebuild is masked or unavailable
  (net-dns/bind-tools-9.12.2_p2-r1:0/0::core-kit, installed): ebuild is masked or unavailable
  (net-misc/ntp-4.2.8_p12:0/0::core-kit, installed): ebuild is masked or unavailable
  (app-crypt/gnupg-2.2.11:0/0::core-kit, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

I've tried manually upgrading readline and bzip2, but that just results in more conflicts.  Any idea what my best path forward is?  Each of the last three upgrades took me several days to work out, and I'm hoping the next two won't have to be as bad.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...