Jump to content
  • 0
nexion

Pulseaudio build fails

Question

Hi, I was using Gentoo x86 for quite a long time and now since I need to upgrade to x64 I decided to switch to Funtoo at the same time. Everything went just fine, portage was up to emerge last ~150 packets, then I got this issue with media-sound/pulseaudio-5.99.3:

configure: error: *** UDEV support not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-sound/pulseaudio-5.99.3/work/pulseaudio-5.99.3-abi_x86_64.amd64/config.log
 * ERROR: media-sound/pulseaudio-5.99.3 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 4829:  Called multilib-minimal_src_configure
 *        environment, line 3765:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *        environment, line 3972:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3696:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3694:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *        environment, line  680:  Called multilib-minimal_abi_src_configure
 *        environment, line 3759:  Called multilib_src_configure
 *        environment, line 4216:  Called econf '--with-database=gdbm' '--disable-bluez5' '--disable-bluez4' '--localstatedir=/var' '--with-udev-rules-dir=//lib/udev/rules.d' '--disable-coreaudio-output' '--disable-esound' '--disable-solaris' '--disable-waveout' '--enable-largefile' '--enable-x11' '--disable-adrian-aec' '--enable-asyncns' '--enable-glib2' '--disable-oss-output' '--disable-oss-wrapper' '--disable-alsa' '--disable-dbus' '--disable-gcov' '--enable-gconf' '--enable-gtk3' '--disable-jack' '--enable-ipv6' '--disable-samplerate' '--disable-lirc' '--disable-bluez5-native-headset' '--disable-neon-opt' '--disable-bluez5-ofono-headset' '--enable-orc' '--enable-openssl' '--disable-systemd-daemon' '--disable-systemd-journal' '--disable-systemd-login' '--enable-tcpwrap' '--disable-default-build-tests' '--enable-udev' '--enable-hal-compat' '--enable-webrtc-aec' '--disable-xen' '--disable-avahi' '--with-caps' '--with-fftw' '--with-speex'
 *   phase-helpers.sh, line  526:  Called die
 * The specific snippet of code:
 *                      die "econf failed"

Full logs:

/var/tmp/portage/media-sound/pulseaudio-5.99.3/temp/build.log

/var/tmp/portage/media-sound/pulseaudio-5.99.3/work/pulseaudio-5.99.3-abi_x86_64.amd64/config.log

emerge --info '=media-sound/pulseaudio-5.99.3'

/var/tmp/portage/media-sound/pulseaudio-5.99.3/temp/environment

 

Udev is surely installed and everything before was emerged with 'udev' global USE-flag.

 

I also tried to mask media-sound/pulseaudio-5.99.3. After that media-sound/pulseaudio-5.0.20141024-r1 emerged successfully, but suddenly its dependencies seems to be not satisfied with this replacement:

 

media-libs/openal-1.15.1-r2:

.......
l-soft-1.15.1/Alc/backends/wave.c
In file included from /usr/include/pulse/sample.h:32:0,
                 from /usr/include/pulse/def.h:30,
                 from /usr/include/pulse/direction.h:25,
                 from /usr/include/pulse/pulseaudio.h:26,
                 from /var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:29:
/var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:107:5: error: missing binary operator before token "~"
 #if PA_CHECK_VERSION(0,9,15)
     ^
/var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:111:5: error: missing binary operator before token "~"
 #if PA_CHECK_VERSION(0,9,16)
.......

media-libs/libcanberra-0.30-r4 (this library is required for gnome3, so I need to build it):

libtool: compile:  x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -I/usr/include/alsa -Ddriver_open=alsa_driver_open -Ddriver_destroy=alsa_driver_destroy -Ddriver_change_device=alsa_driver_change_device -Ddriver_change_props=alsa_driver_change_props -Ddriver_play=alsa_driver_play -Ddriver_cancel=alsa_driver_cancel -Ddriver_cache=alsa_driver_cache -march=core2 -O2 -pipe -c alsa.c  -fPIC -DPIC -o .libs/libcanberra_alsa_la-alsa.o
In file included from /usr/include/pulse/mainloop-api.h:29:0,
                 from /usr/include/pulse/thread-mainloop.h:26,
                 from pulse.c:35:
pulse.c: In function 'pulse_driver_play':
pulse.c:829:63: error: missing binary operator before token "~"
 #if defined(PA_MAJOR) && ((PA_MAJOR > 0) || (PA_MAJOR == 0 && PA_MINOR > 9) || (PA_MAJOR == 0 && PA_MINOR == 9 && PA_MICRO >= 15))
                                                               ^
make[2]: *** [libcanberra_pulse_la-pulse.lo] Error 1

So, what do you think? Did I miss something or should I file an issue in bug tracker?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Nah, I looked inside its dependencies ? it pulls too much flags I don't really need, like nsplugin, print and dvd mix-ins (have none of these devices), also audio mix-in is like it's going to support every possible sound card. So I'm fine with core flavor, gnome mix-in and manually selected use flags, just incidentally forgot to enable alsa flag and got a bit stack due to deluding error message.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...