Jump to content
funtoo forums

nexion

Members
  • Content Count

    7
  • Joined

  • Last visited

About nexion

  • Rank
    Newbie

Personal

  • Location
    Saint Petersburg
  1. Thanks overkill, Daniel! I confirm, downgrading xorg-server to 1.16 is a suitable workaround.
  2. I doubt it may be connected with this issue somehow since I have no emul-linux-x86* packages installed, instead I use abi_x86_32 where it is required.
  3. overkill, I suppose if you run 'ck-list-sessions' as user you'll get the same result: parameter active equals false, while it should be true for local user privileges to work. Yep, I assume it may become broken because of some package update, it definitely happened to me not very long ago. Though I update world quite often and reboot / connect external media too rarely to guess which update may led to this result. Off topic: I just realized portage lacks of rollback function, like 'yum history update' in Fedora. It might be not very complicated thing to realize: just quickpkg all packages (including configs) which are going to be updated and store this update details somewhere. Then if something turns out to be broken, user can choose to have sex immediately or just to quickly rollback to one of saved points where everything is yet fine and have sex later :) Oh, wait... It was already proposed 13 years ago :) Since nobody made it yet, I hope once I'll have enough time and skills to do it myself.
  4. I desperately tried to find a solution myself, but not succeeded. When I am logged in Gnome session via GDM no local user privileges (such as reboot/shutdown, passwordless usb media mount, user session switching) are available to me. No power management options while in GDM login window either. Obviously, the reason is inactive state of consolekit sessions run through GDM: Session6: unix-user = '115' realname = 'added by portage for gdm' seat = 'Seat5' session-type = 'LoginWindow' active = FALSE x11-display = ':0' x11-display-device = '' display-device = '' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:56:13.786129Z' login-session-id = '4' idle-since-hint = '2015-03-30T00:56:15.796297Z' Session7: unix-user = '1000' realname = 'Nexie' seat = 'Seat6' session-type = '' active = FALSE x11-display = ':0' x11-display-device = '' display-device = '' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:56:47.125458Z' login-session-id = '5' When I start Gnome session manually with startx, everything works as expected and consolekit session is active: Session5: unix-user = '1000' realname = 'Nexie' seat = 'Seat1' session-type = '' active = TRUE x11-display = ':0' x11-display-device = '/dev/tty7' display-device = '/dev/tty1' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:54:22.822545Z' login-session-id = '4' .xinitrc ? as recommended in wiki: exec ck-launch-session gnome-session Here are the installed packages which may be relevant: [ebuild R ] sys-apps/dbus-1.8.16 USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="32 (64) (-x32)" 0 kB [ebuild R ] sys-fs/eudev-1.5.3-r2 USE="gudev hwdb introspection keymap kmod modutils openrc rule-generator static-libs -doc (-selinux) {-test}" ABI_X86="32 (64) (-x32)" 0 kB [ebuild R ] x11-base/xorg-server-1.17.1-r1:0/1.17.1 USE="ipv6 kdrive nptl suid udev xorg -dmx -doc -glamor -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb" 0 kB [ebuild R ] sys-auth/polkit-0.112-r2 USE="gtk introspection nls pam -examples -jit -kde (-selinux) -systemd" 0 kB [ebuild R ] sys-auth/consolekit-0.4.6 USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}" 0 kB [ebuild R ] gnome-base/gdm-3.14.1 USE="introspection ipv6 tcpd -accessibility -audit -branding -debug -fprint -plymouth (-selinux) -smartcard -systemd {-test} -wayland -xinerama" 0 kB rc-status shows that consolekit, dbus and openrc-settingsd are running as dependencies. Tried to add them explicitly to default runlevel, nothing changed. Could you give me any suggestion how to solve this or where else to look?
  5. Nah, I looked inside its dependencies ? it pulls too much flags I don't really need, like nsplugin, print and dvd mix-ins (have none of these devices), also audio mix-in is like it's going to support every possible sound card. So I'm fine with core flavor, gnome mix-in and manually selected use flags, just incidentally forgot to enable alsa flag and got a bit stack due to deluding error message.
  6. Solved. Somehow "alsa" wasn't enabled as USE flag.
  7. Hi, I was using Gentoo x86 for quite a long time and now since I need to upgrade to x64 I decided to switch to Funtoo at the same time. Everything went just fine, portage was up to emerge last ~150 packets, then I got this issue with media-sound/pulseaudio-5.99.3: configure: error: *** UDEV support not found !!! Please attach the following file when seeking support: !!! /var/tmp/portage/media-sound/pulseaudio-5.99.3/work/pulseaudio-5.99.3-abi_x86_64.amd64/config.log * ERROR: media-sound/pulseaudio-5.99.3 failed (configure phase): * econf failed * * Call stack: * ebuild.sh, line 93: Called src_configure * environment, line 4829: Called multilib-minimal_src_configure * environment, line 3765: Called multilib_foreach_abi 'multilib-minimal_abi_src_configure' * environment, line 3972: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure' * environment, line 3696: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure' * environment, line 3694: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure' * environment, line 680: Called multilib-minimal_abi_src_configure * environment, line 3759: Called multilib_src_configure * environment, line 4216: Called econf '--with-database=gdbm' '--disable-bluez5' '--disable-bluez4' '--localstatedir=/var' '--with-udev-rules-dir=//lib/udev/rules.d' '--disable-coreaudio-output' '--disable-esound' '--disable-solaris' '--disable-waveout' '--enable-largefile' '--enable-x11' '--disable-adrian-aec' '--enable-asyncns' '--enable-glib2' '--disable-oss-output' '--disable-oss-wrapper' '--disable-alsa' '--disable-dbus' '--disable-gcov' '--enable-gconf' '--enable-gtk3' '--disable-jack' '--enable-ipv6' '--disable-samplerate' '--disable-lirc' '--disable-bluez5-native-headset' '--disable-neon-opt' '--disable-bluez5-ofono-headset' '--enable-orc' '--enable-openssl' '--disable-systemd-daemon' '--disable-systemd-journal' '--disable-systemd-login' '--enable-tcpwrap' '--disable-default-build-tests' '--enable-udev' '--enable-hal-compat' '--enable-webrtc-aec' '--disable-xen' '--disable-avahi' '--with-caps' '--with-fftw' '--with-speex' * phase-helpers.sh, line 526: Called die * The specific snippet of code: * die "econf failed" Full logs: /var/tmp/portage/media-sound/pulseaudio-5.99.3/temp/build.log /var/tmp/portage/media-sound/pulseaudio-5.99.3/work/pulseaudio-5.99.3-abi_x86_64.amd64/config.log emerge --info '=media-sound/pulseaudio-5.99.3' /var/tmp/portage/media-sound/pulseaudio-5.99.3/temp/environment Udev is surely installed and everything before was emerged with 'udev' global USE-flag. I also tried to mask media-sound/pulseaudio-5.99.3. After that media-sound/pulseaudio-5.0.20141024-r1 emerged successfully, but suddenly its dependencies seems to be not satisfied with this replacement: media-libs/openal-1.15.1-r2: ....... l-soft-1.15.1/Alc/backends/wave.c In file included from /usr/include/pulse/sample.h:32:0, from /usr/include/pulse/def.h:30, from /usr/include/pulse/direction.h:25, from /usr/include/pulse/pulseaudio.h:26, from /var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:29: /var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:107:5: error: missing binary operator before token "~" #if PA_CHECK_VERSION(0,9,15) ^ /var/tmp/portage/media-libs/openal-1.15.1-r2/work/openal-soft-1.15.1/Alc/backends/pulseaudio.c:111:5: error: missing binary operator before token "~" #if PA_CHECK_VERSION(0,9,16) ....... media-libs/libcanberra-0.30-r4 (this library is required for gnome3, so I need to build it): libtool: compile: x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -I/usr/include/alsa -Ddriver_open=alsa_driver_open -Ddriver_destroy=alsa_driver_destroy -Ddriver_change_device=alsa_driver_change_device -Ddriver_change_props=alsa_driver_change_props -Ddriver_play=alsa_driver_play -Ddriver_cancel=alsa_driver_cancel -Ddriver_cache=alsa_driver_cache -march=core2 -O2 -pipe -c alsa.c -fPIC -DPIC -o .libs/libcanberra_alsa_la-alsa.o In file included from /usr/include/pulse/mainloop-api.h:29:0, from /usr/include/pulse/thread-mainloop.h:26, from pulse.c:35: pulse.c: In function 'pulse_driver_play': pulse.c:829:63: error: missing binary operator before token "~" #if defined(PA_MAJOR) && ((PA_MAJOR > 0) || (PA_MAJOR == 0 && PA_MINOR > 9) || (PA_MAJOR == 0 && PA_MINOR == 9 && PA_MICRO >= 15)) ^ make[2]: *** [libcanberra_pulse_la-pulse.lo] Error 1 So, what do you think? Did I miss something or should I file an issue in bug tracker?
×
×
  • Create New...