Jump to content
funtoo forums

ANSWERED updating from generic-x86_64 to amd64

Recommended Posts

Yesterday on IRC it was mentioned that there were new details and stage3 binarys for amd64 bulldozer (reference: amd64 bulldozer wiki page).


I grabbed the stage 3 for both variants and did a diff. The only appreciable difference was [C|CXX]FLAGS in the make.conf. Seems simple enough...


But I also noticed that a Pure64 variant of the bulldozer stage 3 was availble. I cannot forsee any use of a 32bits in my future and putting a stop to 32bit stuff seems ideal to me. I have a hex-core Bulldozer and cpu cycles to burn. Must try...


Having already "borked" my system twice and fixed both times without having to re-install, I'm game for an update.

A review of the diff I made between generic x86_64 and Pure64 stage3's suggest the manual changes need to be completed:

- edit /etc/ld.so.conf and remove references to - /lib32,/usr/lib32,/usr/local/lib32

- edit /etc/portage/make.conf: [C|CXX]FLAGS - "-mtune=generic -O2 -pipe" -> "-march=bdver1 -O2 -pipe"

- eselect profile: change "x86-64bit" -> "pure64"

- re-emerge world (-e flag)

- reboot

- manually remove lib32 folders if not already gone.


I think that's it...

If you don't see me here in awhile you know what happend... ;)

Share this post

Link to post
Share on other sites

It can be done...


A couple of things to note:

- there is no method to alter the eselect arch profile on the command line. You have to edit /etc/portage/make.profile/parent manually. Make sense, sort of. Not something to be changed lightly.

- only had to remove /usr/local/lib32 folder (and it was empty). All others were removed with re-emerging.

- /etc/ld/so.conf was re-generated so commenting out lib32 probably not necessary.

- grub-install and boot-update reported success but I had to pull out SystemRescueCD and chroot in to redo grub-install/boot-update in order to boot. (grub-2.02_beta2-r3,boot-update-1.7.1)


So, it works!

Summming up updating generic x86_64 to pure64:

- make sure your system is up to date.

- change your profile (manually edit /etc/portage/make.profile/parent )

- change your make flags (edit /etc/portage/make.conf )

- re-emerge world (emerge -e @world )

- ensure boot loader is set

- perl-cleaner --all (not a requirement - but just to be thorough)

- re-establish file link: ln -s /usr/share/zoneinfo/[your time zone] /etc/localzone


if going from generic x86_64 to Bulldozer, do all of the above except change the profile.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now