Jump to content
  • 0
joachin

pangomm & libreoffice error

Question

Hey guys, having some problems trying to install pango mm:

pangomm

and libreoffice-bin:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.65.0:0/1.65.0::core-kit, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.65.0 required by (app-office/libreoffice-bin-6.2.4.2:0/0::desktop-kit, ebuild scheduled for merge)
                  ^^^^^^^^^                                                                                               

  (dev-libs/boost-1.70.0:0/1.70.0::core-kit, installed) pulled in by
    >=dev-libs/boost-1.65.1:0/1.70.0= required by (sys-fs/cryfs-0.10.2:0/0::core-kit, installed)
    ^^               ^^^^^^^^^^^^^^^^                                                            
    (and 1 more with the same problem)

app-text/hunspell:0

  (app-text/hunspell-1.6.2-r1:0/1.6::text-kit, ebuild scheduled for merge) pulled in by
    app-text/hunspell:0/1.6 required by (app-office/libreoffice-bin-6.2.4.2:0/0::desktop-kit, ebuild scheduled for merge)
                     ^^^^^^                                                                                               

  (app-text/hunspell-1.7.0:0/1.7::text-kit, installed) pulled in by
    app-text/hunspell:0/1.7= required by (kde-frameworks/sonnet-5.59.0:5/5.59::kde-kit, installed)
                     ^^^^^^^                                                                       
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Thanks!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Same problem here. I remove boost which I think I don't need for the time. Thus, `hunspell` remains to be resolved.

emerge -av app-office/libreoffice-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-text/libexttextcat-3.4.5::text-kit  USE="-static-libs" 1,017 KiB
[ebuild  N     ] app-text/libnumbertext-1.0.5::text-kit  276 KiB
[ebuild  N     ] sci-libs/suitesparseconfig-4.2.1-r1::science-kit  USE="-abi_riscv_lp64 -abi_riscv_lp64d -static-libs" 251 KiB
..
[ebuild     UD ] dev-util/boost-build-1.65.0::core-kit [1.70.0::core-kit] USE="python -examples -test" PYTHON_TARGETS="python2_7" 80,662 KiB
[ebuild     UD ] dev-libs/boost-1.65.0:0/1.65.0::core-kit [1.70.0:0/1.70.0::core-kit] USE="icu nls python threads -abi_riscv_lp64 -abi_riscv_lp64d -context -debug -doc -mpi -static-libs -tools (-bzip2%*) (-lzma%) (-numpy%) (-zlib%*) (-zstd%)" PYTHON_TARGETS="python2_7 -python3_5 -python3_6 (-python3_7%*)" 0 KiB
..
[ebuild     UD ] app-text/hunspell-1.6.2-r1:0/1.6::text-kit [1.7.0:0/1.7::text-kit] USE="ncurses nls readline -static-libs" L10N="de el en fr -af -bg -ca -cs -cy -da -de-1901 -eo -es -et -fo -ga -gl -he -hr -hu -ia -id -is -it -kk -km -ku -lt -lv -mi -mk -ms -nb -nl -nn -pl -pt -pt-BR -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu" 705 KiB
..

and

..

Total: 60 packages (3 downgrades, 54 new, 3 in new slots), Size of downloads: 346,068 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/hunspell:0

  (app-text/hunspell-1.6.2-r1:0/1.6::text-kit, ebuild scheduled for merge) pulled in by
    app-text/hunspell:0/1.6 required by (app-office/libreoffice-bin-6.2.4.2:0/0::desktop-kit, ebuild scheduled for merge)
                     ^^^^^^

  (app-text/hunspell-1.7.0:0/1.7::text-kit, installed) pulled in by
    app-text/hunspell:0/1.7= required by (kde-frameworks/sonnet-5.59.0:5/5.59::kde-kit, installed)
                     ^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-office/libreoffice-bin-6.2.4.2::desktop-kit
# required by app-office/libreoffice-bin (argument)
>=dev-libs/xmlsec-1.2.28 nss

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...