Jump to content
funtoo forums
  • 0
Sign in to follow this  
tjones2

dev-libs/libxml2 icu flag -- Installing Anki and Chromium On the Same System

Question

Hi, 

 

I am trying to install the Anki flashcard application on a system that already has Chromium installed. There seems to be an incompatibility involving the dev-libs/libxml2 icu flag -- Chromium needs it enabled while Anki needs it off.  When I run emerge anki I receive the following error (the full stderr and stdout output of the command is attached). Edit: Attached the full output.

 

!!! Multiple package instances within a single package slot have been pulled

!!! into the dependency graph, resulting in a slot conflict:

 

dev-libs/libxml2:2

 

  (dev-libs/libxml2-2.9.2-r1000::gentoo, ebuild scheduled for merge) pulled in by

    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1::gentoo, ebuild scheduled for merge)

 

  (dev-libs/libxml2-2.9.2-r1000::gentoo, installed) pulled in by

    dev-libs/libxml2:=[icu] required by (www-client/chromium-40.0.2214.10::gentoo, installed)

    dev-libs/libxml2:2/2=[icu] required by (www-client/chromium-40.0.2214.10::gentoo, installed)

emergeanki.txt

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...