Jump to content
funtoo forums
  • 0
Sign in to follow this  
i.am.not.a.bot

Fresh 1.4 Install: EGO OSError

Question

I performed a fresh 1.4 base install on my trusty ThinkPad last night. Even though this is only my second attempt to install Funtoo, everything went perfectly smoothly. I called it a night, right after the first reboot. I haven't, as yet, created a regular user account, so I am logging into the machine as root.
The first thing on today's agenda was to configure the machine's flavor and mix-ins and that's where things immediately went wrong:

# epro flavor desktop

===Enabled Profiles: ===

arch: x86-64bit
build: current
subarch: intel64-ivybridge
flavor: desktop
mix-ins: (not set)

>>> Set flavor to desktop.
Updating profiles at /etc/portage/make.profile/parent...
ERROR: EGO encountered an unexpected error: OSError
ERROR: Unable to write full traceback.

 

Indeed, if I enter #epro show after receiving this EGO error message, the desktop flavor does not "stick."

The file's permissions are as follows:
 

/etc/portage/make.profile # ls -l
total 4
-rw-r--r-- 1 root root 1529 Sept 11 23:57 parent

 

Based on the permissions, I'm not sure why EGO should be encountering difficulties, but: when opening the file "parent" in nano, there is a message in the lower center of the window, stating that [ File 'parent' is unwritable ]

As I mentioned at the beginning, I'm a complete Funtoo noob, so I am having some difficulty locating EGO diagnostic information. I see a few assorted EGO errors documented here in the forum, but none appear to be related to my dilemma. Should I skip ahead and install logging capabilities,  or is there a better approach? I'd be grateful if someone could nudge me in the right direction.

Thanks in advance!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

What are the permissions of the directories above?

Do you have enough free space available (in all partitions)?

Any error messages, e.g. in dmesg?

Can you read the contents of the file?

An OSError can be a lot of things. Unless you can find more information, there isn't much to say.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, jhan said:

What are the permissions of the directories above?

Do you have enough free space available (in all partitions)?

Any error messages, e.g. in dmesg?

Can you read the contents of the file?

An OSError can be a lot of things. Unless you can find more information, there isn't much to say.

 

Thanks very much for responding, jhan, but I've sorted this out. When I looked earlier, I completely missed a dmesg entry having to do with mounting disk partitions, which ultimately led me to the solution.

I have a pre-existing Solus installation on this machine. By way of preparation, I went ahead and used GParted to create my Funtoo partitions in some unused disk space. I also added a data partition at this time, which could be shared between Solus and Funtoo. At the conclusion of the partitioning and formatting, I ran $ sudo blkid from Solus and copy/pasted the output, so that I would have the UUID of the data partition (and indeed all of the disk partitions), when installing Funtoo.

When I edited Funtoo's fstab file, I used some of Solus' partition mounting conventions, such as errors=remount-ro. And indeed, I had an error. So, it wasn't just the /etc/portage/make.profile/parent file that was unwritable, but the entire disk! Only ... parent was the first and only file that I tried to edit (through EPRO) today.

So, long story short, tidying up my fstab file has allowed me to set the flavor for Funtoo.

Thanks again for responding so quickly.

Cheers!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...