Jump to content
funtoo forums
  • 0
nigga-china

surf browser doesn't compile and other issues.

Question

I tried to compile surf browser from source code but it needs gcr-3.pc although there is only gcr-base-3.pc in $PKG_CONFIG_PATH (/usr/lib/pkgconfig). I emerged webkit2-gtk, gstreamer, gtk+, gcr and all dependencies that I found but gcr-3.pc continues missing. Some days ago I've emerged surf by source code without problems, but after reinstalling Funtoo on my notebook seems that some things just don't worked anymore. For example ZSH doesn't export the path variable properly after the Funtoo updating to 1.3, so I can't use almost all programs, also I changed my default user shell to bash but seems that shopt options also doesn't work properly (e.g. shopt -s nocaseglob and shopt -s nocasematch doesn't garantee the match case, I have to type using the correct case).

I tried find help searching about this surf issue, but almost all problems I saw could be corrected exporting the PKG_CONFIG_PATH or installing the gcr lib, but I already did it and it keeps don't working. I suspect that it might be some package that doesn't installs properly (I also already reemerged a lot of packages), so because it I'm posting it here. I have to say that I also tried to install surf by just emerging it and it worked fine, but I don't like to emerge suckless programs (I do install it by compiling the source code) because most of them is not in the last version on Portage (like dmenu, st, etc) and because patching a package on Portage is not so simple as patching the source code and doing "sudo make clean install".

My log file when I tried to "make" surf is attached in here.

log.txt

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
5 hours ago, jhan said:

Do you have set the gtk USE flag for the gcr package? You need that to get the file gcr-3.pc

Thank you a lot, it solved my issue. Do you recommend I set USE globally with these kind of flags? E.g.: USE="alsa gtk -pulseaudio qt5 X" and so on... My use flags currently is like this USE="bash-completion minimal xinerama zsh-completion". I disable the minimal flag in some cases (e.g. for nano text editor) although.

Share this post


Link to post
Share on other sites
  • 0

I personally set only those USE flags globally that I want to be set for all packages, if they are not already set by the chosen profile. If I want to change a USE flag from the default for just a few packages I use package.use but I try to keep that to a minimum.

Share this post


Link to post
Share on other sites
  • 0

Can you show me your USE flag to I have an idea?

After building surf, when I try to open some sites as google, soundcloud, youtube, etc surf closes and leaves this message "web process terminated: crashed". I suspect that's because I didn't set some flag to surf dependencies. This issue doesn't occur when I open simple sites (e.g. suckless.org). I have installed almost all gst-plugins and it didn't solve this crash issue.

Share this post


Link to post
Share on other sites
  • 0
39 minutes ago, jhan said:

Which USE flags do you mean? The ones for surf?

No, I mean the global USE in make.conf. I built surf from source code, so Portage USE flags doesn't matter.

When I emerged surf by Portage some pages like google.com didn't show nothing too. The only difference is that the emerged surf didn't close, it just showed a black empty screen instead the usual white empty screen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...