Jump to content
  • 0

Boot stops at the end until I press any key


skyark
 Share

Question

So this is strange...

I just install funtoo in my Lenovo Y700 whit KDE and everything was running fine just have uno minor issue, the boot time netmount and networkmanager they just stop for a few seconds, then it resume my boot and that was it.

First i just did this in the /etc/rc.conf

rc_hotplug="!net.*"

And it did the job then i was installing acpi, laptop for power manager, configuring the nvidia driver, trying to get working with the intel driver too. Everything was Ok but then I notice that the boot process just stop and I have to hit a key (any key) to resume the boot process, just like that.

The first thing that y did was to remove services from the RC first the netmount, then the networkmanager then the acpi, laptop, ssh and nothing work, just at the end i have to hit any kit and the sddm show up.

i dont know why i just try to install bootchart to try to understandit but i coudnt make it work.

put the interactive mode whit RC and like i am hit a key just boot up ok.

this is the rc.log

rc sysinit logging started at Tue Jun 11 09:39:53 2019


   OpenRC 0.40.2 is starting up Funtoo Linux (x86_64)

Press I to enter interactive boot mode

 * /proc is already mounted
 * Mounting /run ...
 * /run/openrc: creating directory
 * /run/lock: creating directory
 * /run/lock: correcting owner
 * Caching service dependencies ...
 [ ok ]
 * Caching service dependencies ...
 [ ok ]
 * Clock skew detected with `(null)'
 * Adjusting mtime of `/run/openrc/deptree' to Tue Jun 11 16:34:11 2019
 * WARNING: clock skew detected!
 * Mounting security filesystem ...
 [ ok ]
 * Mounting debug filesystem ...
 [ ok ]
 * Mounting config filesystem ...
 [ ok ]
 * Mounting persistent storage (pstore) filesystem ...
 [ ok ]
 * Mounting efivarfs filesystem ...
 [ ok ]
 * Mounting cgroup filesystem ...
 [ ok ]
 * Remounting devtmpfs on /dev ...
 [ ok ]
 * Mounting /dev/mqueue ...
 [ ok ]
 * Mounting /dev/shm ...
 [ ok ]
 * Creating list of required static device nodes for the current kernel ...
 [ ok ]
 * /etc/init.d/udev uses runscript, please convert to openrc-run.
 * Starting udev ...
 [ ok ]
 * Generating a rule to create a /dev/root symlink ...
 [ ok ]
 * Populating /dev with existing devices through uevents ...
 [ ok ]
 * Waiting for uevents to be processed ...
 [ ok ]

rc sysinit logging stopped at Tue Jun 11 09:39:53 2019


rc boot logging started at Tue Jun 11 09:39:53 2019

 * WARNING: clock skew detected!
 * Loading module coretemp ...
 * Failed to load coretemp
 [ !! ]
 * Loading kernel modules ...
modprobe: ERROR: could not insert 'nvidia': Module already in kernel
 [ ok ]
 * Setting system clock using the hardware clock [Local Time] ...
 [ ok ]
 * The binfmt-misc module needs to be loaded by the modules service or built in.
 * Mounting misc binary format filesystem ...
 [ ok ]
 * Loading custom binary format handlers ...
 [ ok ]
 * Checking local filesystems  ...
/sbin/fsck.xfs: XFS file system.
fsck.fat 4.1 (2017-01-24)
/dev/sda1: 583 files, 20884/127746 clusters
 [ ok ]
 * Remounting root filesystem read/write ...
 [ ok ]
 * Remounting filesystems ...
 [ ok ]
 * Updating /etc/mtab ...
 * Creating mtab symbolic link
 [ ok ]
 * Activating swap devices ...
 [ ok ]
 * Mounting local filesystems ...
 [ ok ]
 * Configuring kernel parameters ...
 [ ok ]
 * Creating user login records ...
 [ ok ]
 * Wiping /tmp directory ...
 [ ok ]
 * Configuring /etc/hosts ...
 [ ok ]
 * Setting hostname to SykLPC ...
 [ ok ]
 * Setting terminal encoding [UTF-8] ...
 [ ok ]
 * Setting keyboard mode [UTF-8] ...
 [ ok ]
 * Loading key mappings [la-latin1] ...
 [ ok ]
 * Bringing up network interface lo ...
 [ ok ]
 * Saving key mapping ...
 [ ok ]
 * Saving terminal encoding ...
 [ ok ]
 * Initializing random number generator ...
 [ ok ]

rc boot logging stopped at Tue Jun 11 16:39:54 2019

rc default logging started at Tue Jun 11 16:39:55 2019

 * WARNING: clock skew detected!
 * Starting dbus ...
 [ ok ]
 * Starting metalog ...
 [ ok ]
 * Starting consolekit ...
 [ ok ]
 * Starting NetworkManager ...
 [ ok ]
Conectando.....              1sConectando......             1sConectando.......            1sConectando........           1sConectando.........          1sConectando..........         1sConectando..........$
 * Marking NetworkManager as inactive. It will automatically be marked
 * as started after a network connection has been established.
 * WARNING: NetworkManager has started, but is inactive
 * Starting acpid ...
 [ ok ]
 * No bootchart process found!
 *   This script does not start bootchart, but only schedules its termination.
 *   Bootchart should be started from the kernel command line.
 *   Please check the README on how to do that.
 [ ok ]
 * Starting cupsd ...
 [ ok ]
 * Starting laptop_mode ...
 [ ok ]
 * Initializing sensors ...
 [ ok ]
 * WARNING: netmount will start when NetworkManager has started
 * Starting sshd ...
 [ ok ]
 * Starting thermald ...
 [ ok ]
 * Setting up sddm ...
 [ ok ]
 * Starting local ...
 [ ok ]

rc default logging stopped at Tue Jun 11 16:40:23 2019

 

Any clues?

 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...